Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using the vim plugin called powerline and it isn't showing the git branch I'm on, while it's supposed to be activated by default. The fugitive plugin is installed, though I don't think it was required. Is there anything else I'm supposed to do for it to work?

share|improve this question
add comment

3 Answers

Try running :PowerlineClearCache. The branch is not activated by default.

share|improve this answer
add comment

you should have fugitive installed, if you have it already and yet it does not show, and :PowerlineClearCache doesn't help then try removing Powerline_default_default_compatible.cache from powerline plugin folder and restarting vim.

share|improve this answer
add comment

If you are sure that the let g:Powerline_symbols = 'fancy' option works well (the array symbol and the LN symbol are displayed normally as in the screenshot) then try running :PowerlineClearCache in any vim session then restart your vim. Or you should patch your font first.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.