Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I searched Google and SU for my problem, but everybody seems to want to add diacritics, while I don't want them.

I'm using Windows 7 and have a US keyboard installed, not the international version. Despite that some keys, like ", ^ and ~ are used for diacritics, which means that I have to type "SPACE to get a double quote. How do I get rid of this? My other PC, with the same settings, doesn't show this behavior.

edit re Stefan's answer
I don't see the icon Stefan refers to in my taskbar, probably because I have Classic Shell installed. But this is a screenshot of the Input Languages dialog, there are no other keyboards installed:

enter image description here

share|improve this question
    
Can you verify that you have selected the correct EN (US) version? Here is a picture showing the popup which appears when you click on the little keyboard icon in the taskbar. It should be set to "US", not "International" as in the picture. !Keyboard settings popup –  Stefan Seidel Sep 7 '12 at 14:53
    
Thanks for the reply, Stefan. Updated my question. –  stevenvh Sep 7 '12 at 15:12
    
@stevenvh Try right-clicking on empty task bar area, and see if there's an option called "Language Bar" under "Toolbars" at the top of the menu. –  Darth Android Sep 7 '12 at 15:19
    
@Darth - Nope, there isn't one. But I found the solution, see my answer. Thanks for the feedback, though. –  stevenvh Sep 7 '12 at 15:38
    
Based on your answers on EE.SE, I bet you could just slap a couple op-amps and resistors in your keyboard somewhere to eliminate them! –  Ward Sep 7 '12 at 17:37
add comment

1 Answer

up vote 3 down vote accepted

OK, I found it. Apparently removing the other keyboard and selecting the US version doesn't disable the other one, you still have to switch manually. Those who use Classic Shell, like me, may not see the keyboard icon, but you can use a keyboard combination for the switch.

enter image description here

A newly added keyboard will show under the tab Advanced Key Settings with no key sequence assigned. Temporarily assign one, like Ctrl0, and use the combination to activate the new keyboard layout. If you don't have other keyboards configured you can remove the key sequence again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.