Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a self built computer. it uses a P6T Deluxe motherboard, which has both SATA and IDE ports. This was built several years ago, and had an IDE CD/DVD drive. This drive started going bad (would not burn CDs correctly), so I decided to replace it. I had difficultly finding an IDE DVD drive, so I bought a SATA DVD drive.

I opened the comnputer, took out the old DVD drive. I left the IDE cable in place, connected to the motherboard, but it is not connected to any drives. I hooked up the new DVD drive, both power and with a SATA data cable (SATA port 3 if I recall). (Sony Optiarc 24x , Newegg URL: http://www.newegg.com/Product/Product.aspx?Item=N82E16827118067 )

When I power on my computer, the drive does NOT show up in Explorer. I can hit the DVD eject button, and the drive will open up, so I know it at least is getting power.

I thought, maybe something in the BIOS. When I go to BIOS, boot devices, it shows (1) floppy, (2) my hard drive (3) ATAPI CD Drive. The only other possible BIOS option I could find was uder 'Storage Configuration'. Configure Storage as: My setting is RAID, since I am using two drives in a RAID configuration. Other options were IDE and ACHI.

Other than trying to find an IDE DVD drive, is there anything else I can try? The drive does not show up at all in Windows Explorer. I did put in a CD thinking that might help, but nothing happened.

Thanks, GS

share|improve this question
    
Have you tried booting to the CDROM? What its detecting in the bios might be a ghost of the old one. See if it is bootable, then we can rule out the bios as a factor. –  francisswest Sep 7 '12 at 15:59
    
I tried changing BIOS boot order to look at ATAPI CD-ROM. I put a bootable CD in the drive (Memtest ISO) and rebooted. The computer did not even appear to look at the DVD-Drive during bootup. My BIOS also has a utility to specify who where to boot from. I tried this as well. It is basically a POPUP menu for boot devices. It only shows floppy and hard drives. it does not even list a CD/DVD drive. It appears I have either a bad drive or a bad SATA port. Is there any other possibilities? –  user1009073 Sep 7 '12 at 17:18
    
Bad power cable as well....does it spin up/light up at all? –  francisswest Sep 7 '12 at 18:31
    
It does NOT spin up at all when I put in a disk, but when I hit the DVD eject button, the 'access light' comes on and the door opens, then the light goes off after about 4 seconds. I hit the eject button again, and the door closes. But it still does NOT spin up. –  user1009073 Sep 7 '12 at 19:40
1  
Sounds like either a bad sata cable, sata port, or bad drive. The first 2 are easy to check. Swap the sata cable from your hdd with your optical drive. Computer boots? sata cable is fine. restore the original config. now put the known good sata cable into a different sata port if you can. –  francisswest Sep 7 '12 at 20:37

1 Answer 1

Ended up going with an IDE CD Drive I pulled from another computer. Never did find out what it was...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.