Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to know the bus address of my video controller to fix a problem about the brightness keybinding on Debian Wheezy.

I did lspci | grep VGA

and the result is:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 520MX] (rev a1)

My question is which address from 00:02.0 and 01:00.0 I have to take?

share|improve this question
up vote 1 down vote accepted

I'm just going to guess and say you have an Asus laptop where the fn key is required to adjust brightness. Secondly, I'm going to guess that instead of the "flicker" problem, you can't get the brightness to adjust at all.

If any of the above is true please proceed. Otherwise you might fill in some more info such as what you're planning to doing with the bus id of your gpu and hdmi audio contoller.

Possible solution:

  • open /etc/X11/xorg.conf

  • under “Device” add

    Option "RegistryDwords" "EnableBrightnessControl=1"

  • reboot

EDIT I can't comment due to low privileges on this SE so I'll have to respond up here. You have two graphics cards.The first bus ID (00:02.0) is the graphics card that is built directly in the mother board. The second one (01:00.0) is your HDMI out cable for the nvidia card and (depending on the model of ASUS) is likely the one that is controlling your laptop's internal monitor. Whatever you're trying to do, you should probably do it to the second bus id 01:00.0.

share|improve this answer
Yes I have an Asus, but I don't have any "flicker" problem. I'm going just to understand why the command xdev don't show any signal from Fn+F5 and Fn+F6 although the keys work well. – Kyrol Sep 7 '12 at 16:54
How did you know it was HDMI? – CMCDragonkai Jan 24 at 11:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.