Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ubuntu 12.04 is not booting up it shows a black screen with this error:

sulogin: cannot open password database

I tried using the root console from the recovery mode, but it shows the same error . I also tried this method but it didn't worked either.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

It seems that you have corrupted your /etc/passwd

Try to boot a rescue system from the ubuntu install cd or sysrescuecd from cd or usb. Then try to mount the root partition and inspect the /etc/passwd.

On normal systems the credentials are in the file /etc/shadow. Either disable this behavior with shadowconfig off or take care that both files are in sync.

share|improve this answer
    
I tried renaming the passwd file but it didn't helped. What should I do ? –  Torpido Sep 8 '12 at 6:05
    
Without`/etc/passwd` you are not able to log in. You have to find the error inside the file. As a workaround you can use the /etc/passwd from your rescue system. –  user86064 Sep 8 '12 at 12:21
    
Finally I got it to work. I installed the ubuntu in virtual machine and copied the passwd, shadow, gshadow and group files from '/etc/' and pasted them in the ubuntu partition. ( I have a dual boot system win7 + ubuntu ) . Thanks ! for your help ;) –  Torpido Sep 9 '12 at 18:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.