Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had a RAID0 array that for all intents and purposes went to hell. I put a new SSD (same on-board Intel controller) and installed a new copy of Windows on it and all the drivers (Intel Rapid Storage, etc.). I failed to change the SATA type from RAID to AHCI when I did this though.

I have removed the old SSDs that were in RAID0 and if I change the SATA type to AHCI in the BIOS, Windows will not boot. It tries and fails. It then goes into the whole 'let me fix your woes' routine, only to tell me it cannot fix my woes.

The only help I could find was the following:

Locate and then click one of the following registry subkeys: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV In the right pane, right-click Start in the Name column, and then click Modify. In the Value data box, type 0, and then click OK.

That is going from SATA to AHCI I think, but either way my values are already 0.

It seems to work okay, except for the fact that I'm running a 256K Samsung 830 and my read speeds are 226MB/s which is about half of what I should be getting...

Any help would be great. I would REALLY love to not have to reinstall Windows and all apps again...

share|improve this question
1  
+1 for the question. I ran into the same problem with Dell latitude laptops which came withthe options IDE/AHCI/Fake RAID. Sadly the default setting was Fake RAID. I ended up reinstalling and recreating images. –  Hennes Sep 8 '12 at 0:07
1  
If I don't get a reply shortly I'm going to uninstall my RAID drivers and reboot. Otherwise, I'm going to reinstall and recreate my image :( –  Greg-J Sep 8 '12 at 0:12
    
@Greg-J I think you should uninstall Intel Rapid Storage RAID drivers prior to changing to AHCI from RAID in system BIOS so Windows will already have AHCI driver ready after you enable AHCI mode in BIOS. I am not sure if it can be pulled of, but you could try to use feature "Add New Hardware" in Control Panel first to choose and replace with generic Windows AHCI driver instead of restarting laptop, but not sure whether it will work out. –  Boris_yo Oct 4 '12 at 13:31

1 Answer 1

up vote 4 down vote accepted

Check these keys for Intel chipset, set to 0

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Msahci\Start
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV\Start

Changing from RAID to AHCI, you may need one more step. Msahci driver requires Atapi.sys miniport to be loaded during boot as well.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\atapi\Start

For AMD chipsets

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\nvstor\Start
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\nvraid\Start
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\amdsata\Start (non raid)

If You are not able to boot up thanks to BSOD, try out booting to Safe Mode and setting those Registry keys.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.