Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have what I thought initially was a common problem. I use a Windows XP Professional VM for work on a daily basis. I was running out of space and I chose to use vmware-vdiskmanager to grow the disk to 100GB from 40GB. I followed some commonly accepted practices and attached the vmdk to a different VM in order to use diskpart to extend it. The extend succeeded and I shut the VM down properly, disconnected the vmdk, and reattached it to its proper home.

After booting the VM I got the infamous blinking cursor after POST. F8 did not do anything. I'd seen this before so I popped in the Windows XP CD, did a recovery mode, ran bootcfg /rebuild, fixboot and fixmbr. But now the problem had changed: the cursor still blinked on the blank screen, but now it was spewing blank characters all over the screen (resulting in the cursor jumping wildly all over the place.)

I tried to repair the installation using the XP CD; same boot time spam. I tried the alternate MBR that Ubuntu provides; same thing (after the MBR successfully chainloaded the boot sector of Windows, proving that the MBR is not at fault.)

I even tried to install a new copy of Windows next to the other one to see if that would work, but no.

I looked at the BIOS and restored the defaults. Still nothing. I set "Large Disk Access Mode" to "Other" instead of "DOS" since I did grow the disk. Didn't help either.

What else should I be looking at? I'm at my wit's end. I thought I understood x86 booting arcana, but it's clear I'm totally missing something. I'm a couple steps short of dumping and disassembling the boot sector to see what it's reading off the disk.

share|improve this question

1 Answer 1

I answered my own question.

Apparently the geometry of the disk had changed during the extension and for some reason it wasn't updated in the boot sector (probably because the second VM did not see it as a bootable disk, so found no reason to update the boot sector?)

So I used TestDisk to rewrite the "BPB" (the section of the boot sector that describes the volume at boot time so that a jump to the correct part of the HD can be achieved) and rebooted. Still this didn't work, the directory listing was inaccessible in the recovery console. So in went another round of fixboot and fixmbr. BAM, it works again, finally.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.