Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows Server 2003 and Linux installed on one hard drive [on separate partitions]. My first partition is the linux boot partition, and maintains Grub. When I boot the Windows partition and shut down W2k3 keeps modifying the MBR to boot directly, and only to the Windows partition. How do I prevent this behavior? I rather like using Grub to make boot selections.

share|improve this question

migrated from stackoverflow.com Sep 8 '12 at 12:34

This question came from our site for professional and enthusiast programmers.

    
This site does offer help with OS related issues (as seen by the tags) –  monksy May 28 '09 at 2:26
1  
@steven. Please post your grub.conf plaese –  Alex Bolotov Jun 13 '09 at 18:46

3 Answers 3

up vote 0 down vote accepted

This was fixed because the "makeactive" option was enabled for the Windows 2k3 option. Taking out that option fixed the issue and still boots windows.

share|improve this answer

Try to nstall GRUB on the first sector of the /boot partition, not in the MBR.

share|improve this answer
    
Then you can copy GRUB's boot sector into a file in windows, and add it to the Windows boot menu. –  Peter Cordes Dec 10 '09 at 4:59

Perhaps the motherboard has the "boot sector virus protection" option?

share|improve this answer
    
Nope. Windows 2003 changes the MBR in fdisk. –  monksy May 28 '09 at 2:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.