Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using MSI U115 11" netbook (OS: Windows XP Home, graphics card: Intel Graphics Media Accelerator 500) and today after I switched it on, desktop was bigger than screen.

To be exact: screen resolution was set to the lowest possible and I could move mouse outside of screen (but only below - left, right and up worked normally, mouse could not exceed screen boundaries). I changed resolution back to normal, but the problem with desktop being bigger than screen remained (as before, only lower part - cannot see task bar, etc. When I hit windows button on keyboard, only upper part of menu start is visible).

What I already tried was changing all kind of graphics and screen settings - none of them helped. I also tried to restore the system to few days before, but it didn't help neither.

What can I do to make the desktop look "normally"?

EDIT:

Some additional info regarding screen:

screen choice

Sorry it's in polish - but let me explain. There are two screens I can choose (Monitor domyślny means default screen), but the second one (the default one) is not available. After I choose it and click apply number 1. is used (and as you can see it has only two resolutions available. There are more in the second one - but without 1024x600 though).

The two ticked and grayed out options here are Use this screen as the main one and Enlarge Windows desktop to match this monitor's size. Too bad I cannot change them. When I choose the second screen, the first box is unchecked and grayed out. The second box is available to be changed but it doesn't matter anyway as after applying changes it reverts to the first screen anyway.

EDIT:

Intel Graphics Media Control Panel screenshot.

Intel Control Panel

share|improve this question
    
what monitor do you have ? sometimes there are some buttons on them that you can adjust screen size , position , colour ect. –  Paul Sep 8 '12 at 18:06
    
the problem regards netbook so there is no external monitor - hence, no buttons on it. But the idea itself may be worth checking. I will plug it to external monitor and see if I can adjust anything. –  alex Sep 8 '12 at 18:13
    
Everything is alright when I plug another monitor. But still not working properly on netbook. –  alex Sep 8 '12 at 18:20
add comment

2 Answers

Do you have the Intel Graphics Control Panel on there? It looks like this:

Intel Graphics

If you do then you should be able to select custom resolution and change scaling options.

Alternatively, you can try changing your video resolution to anything you want using regedit. Do this at your own risk - it's recommended you back up your registry before tweaking it. Also, don't go over your video cards min/max resolution.

  • Navigate to:

    HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\VIDEO\{3A2C2EBE-ECDB-4A7B-99EC-58117AFDC5E2}\0000\Mon22446688
    
  • Find DefaultSettings.XResolution. That is your y axis. Edit as a decimal to what you want it to be = 1024

  • Find DefaultSettings.YResolution. That is your x axis. Edit as a decimal to what you want it to be = 600
  • Restart, and you're done

hmm it could be a problem with your graphics drivers heres the 3.3 version from the intel website : http://downloadcenter.intel.com/Detail_Desc.aspx?lang=eng&DwnldID=18472 if you already have this version then try uninstalling the one you have and install this one then restart and hopefully it works

share|improve this answer
    
Why are you posting so many answers? Please pick one answer and edit it. Also, please try to use proper capitalization in your posts. –  Oliver Salzburg Sep 8 '12 at 19:46
    
Sorry this is one of my first times using this site. –  Paul Sep 8 '12 at 19:47
    
That's alright :) Welcome to Super User. But please try to pick one of your answers and add the content from the other answers to it. You can also use the formatting tools to give your post more structure if it gets longer. Cheers :) –  Oliver Salzburg Sep 8 '12 at 19:49
    
Will doo thanks :) –  Paul Sep 8 '12 at 19:55
    
My Intel Control Panel is a bit poorer. Added screenshot for reference. I also tried changing the registry - after reboot resolution seemed like very low. Then explorer.exe did not start properly, but after a second or two everything automatically switched back to normal (i mean the not-good-normal). So were registry records. Back to 1024x768. –  alex Sep 8 '12 at 20:34
show 2 more comments
up vote 0 down vote accepted

I was recently told that this is a hardware issue (the problem occurs randomly in some MSI netbooks) and there is nothing anyone can do about it. Except for replacing the graphics card with a new one. Oh, well. Too bad.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.