Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was looking for a way to portfoward 0.0.0.0 default gateways and I found in a Microsoft page that I had to try the command route delete 0.0.0.0, my internet disconnected and I couldn't connect to the internet anymore... Does anyone have a solution? It's an ADSL Modem.

I have:

  • Windows 7 x32
  • 4 GB ram
  • A kanji modem that has this problem too...

It's like Windows doesn't detect the wireless adapter, so it won't connect to the internet.

share|improve this question

1 Answer 1

In my experience, Windows has the very annoying habit of automatically recreating the 0.0.0.0 route for no apparent reason. Through the Network and Sharing Center, the troubleshooter will probably manage to fix this automatically. Simply disconnecting and reconnect might too. If that fails, reboot.

Deleting the 0.0.0.0 effectively disables the standard gateway. Traffic for which no known specified route exists, as is the case for most destinations on the internet, should be sent to the router, but your OS doesn't do that anymore. Instead, it instantly determines there is no route for your destination and gives up. You can manually restore the route through the command line using: route add 0.0.0.0 mask 0.0.0.0 192.168.1.1, replacing the third IP by the address of your gateway.

share|improve this answer
    
+1, disabling/enabling adapter is normally enough to recreate it –  wmz Sep 8 '12 at 15:12
    
the adress of my gateway? how can i get that, every time before this that i wrote ipconfig in the cmd the default gateway was 0.0.0.0, i just write route add 0.0.0.0 mask 0.0.0.0 0.0.0.0? –  Santiago Sanchez Sep 9 '12 at 23:45
    
how can i disable/enable my adapter? the more information you gve me , the faster i will solve the problem :P –  Santiago Sanchez Sep 10 '12 at 1:19
    
'0.0.0.0 mask 0.0.0.0' means the route is valid for all addresses, hence default gateway, but 0.0.0.0 is not the IP of the gateway itself. Generally, you would use the LAN-IP of your router. DHCP does that automatically. You can disable the interface through the Network and Sharing Center: Change adapter settings, select the interface and click Disable. –  Marcks Thomas Sep 10 '12 at 13:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.