Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Edit: A random crash and a restart fixed this. Probably a restart would have sufficed.

I recently got a TrueBlue TB-100T3 and tried pairing it with my computer (Windows 7 64-bit). At first it paired, but it would not appear under Sound Devices.

I updated my Broadcom Bluetooth drivers here: http://www.broadcom.com/support/bluetooth/update.php

Now my headset appears in both Playback and Recording, but shows as Disconnected. The device is on, paired, and appears under "Device Manager" as having no problems. I right-clicked and installed both the Hands-free Telephony and Headset services.

Here is an image:

Right-clicking the device and selecting Connect does nothing. Does anyone have a solution?

The OP has reported that this problem was resolved by a reboot and has not returned to Super User in 2½ years.

share|improve this question
    
Post your edit as an answer to your question, then accept it so we know your problem is resolved. – bwDraco Sep 16 '12 at 17:29

12 Answers 12

Windows currently has two ways for adding devices:

  1. Double clicking on the Bluetooth icon on the taskbar
  2. Using "Devices and Printers" in the Control Panel

Don't mix the two methods, as they seem to be incompatible. They do stuff differently and ultimately you end up having a mess of drivers.

The most likely solution is doing a clean install from the start.

  • Right click the Bluetooth icon on your taskbar and choose "Open settings". Go to the hardware tab and see if the device you're having trouble with is listed. If it is... Click on properties - Then on the new pop-up menu click in "Change settings" now go to driver and Uninstall the driver.
  • Double click the Bluetooth icon and remove the device you're having trouble with.

Allow some time for Windows to do the magic. Yep, even if the device is gone. There are background tasks that are performed after you removed a device. I'd say two minutes is safe before starting the next step.

  • Go to Device Manager and get rid of the Bluetooth driver.
  • Install the Bluetooth stack/driver via scan new hardware, or by plugging it again.
  • Press (Windows)+R - type services.msc
  • Locate these two services:

    • Bluetooth hands-free
    • Bluetooth Support Service

    Stop the latter. It will prompt you that this will also finish the hands-free services, that's okay. Now start the Bluetooth support service again.

  • With your headphones off do the fancy stuff you do whenever you want to get them in Pair mode (most headphones require you to press the play button 5 secs before turning them ON).

  • Double click the Bluetooth icon on the taskbar.
  • Add the device manually. If prompted to use a passkey, use 0000 (that's Zero Zero Zero Zero).
  • Locate your mixer icon on your taskbar, it should look like a speaker. Right click it and choose "Playback devices". Click on your newfound, newly-paired, HOPEFULLY not disconnected headphones and right-click them to set them as your default playback device.
share|improve this answer

After a good two hours playing with all kinds of settings and following (or trying to follow) each suggestion above, it turns out my speaker (Philips SBT75) can only be connected to one device at a time. I had already tested it successfully with my iPhone and was puzzled that both my iPad and my PC showed as paired but disconnected. I tried everything to get them to connect, to no avail. In the end it was just a matter of clicking on "disconnect" on my iPhone Bluetooth settings, and voilà! I feel silly, but I decided to write this anyway in case it helps someone else.

share|improve this answer
  • Go to your Bluetooth icon left click it menu will open

  • Go up click Show Bluetooth devices left click it now your in the Control Panel\Hardware and Sound\Devices and Printers

  • Place your device in pairing mode and hit Add a device when you see your device click on it to add it and the drivers

  • After your drivers have installed, go Back to Control Panel\Hardware and Sound\Devices and Printers Now right click on your bluetooth headset

  • Go down to properties left click

  • Now your in the headphone properties go over to Services left click it

  • Now click or highlight these boxes

    1. Audio Sink
    2. Handsfree telephony
    3. Headset
    4. Remote control
    5. Remotely controllable device
  • After highlighting or checking these boxes click Apply and more drivers will install after drivers finish

  • Now Reboot your laptop or pc

On some headphones there are more options but these are the only ones that i have used when connecting to my laptops

I have Hp laptops #1: Dv7 and #2: G Series both with two different Bluetooth toggles installed

Settings are the same for most headphones and all i have owned hope this helps.

Snapshot1

Snapshot2

share|improve this answer

After trying several drivers and configurations, I resolved a similar problem by simply setting as default device the Bluetooth Hands-free audio device.

enter image description here
Setting the Bluetooth Hands-free Audio device as the default device

After driver installation default was Bluetooth audio renderer device, I had to change the default device. Now it works seamlessly. No more disconnections

share|improve this answer
    
You should post the setting default info here - if the link breaks in the future your answer would become devalued. – suspectus Oct 20 '15 at 8:22
    
@suspectus The setting default info is shown in the screenshot which has been embedded. – karel Oct 20 '15 at 9:58
1  
I can't select my device as the default device. Any ideas of why this might happen? I see an option to connect, but it doesn't seem to work or do anything. – user3731622 Dec 9 '15 at 2:23

I just wanted to post a more up to date version of the current selected answer. I went to the devices and printers window as well, but from there I:

  • Right clicked the bluetooth headphones and clicked services
  • Then I clicked Listen To music

And I saw my headphones in playback device options go from disconnected to ready almost immediately.

share|improve this answer
    
I'm trying to use Beats Studio wireless headphones. I think I got the device to pair. However, when I select services, there is no "Listen to Music" or any other service listed. Any ideas why? – user3731622 Dec 9 '15 at 2:21
    
It could be related to the blue tooth driver on your computer. The one I have with my new computer is finding my headphones, but won't play any sound through them since it thinks it isn't the right kind of blue tooth driver (which I didn't know was a thing). – Jicaar Dec 17 '15 at 20:47

This question is a year old but I had the same problem and solved it a different way and just wanted to share the solution that worked for me:

1. Go to Devices & Printers
2. Right Click the icon for the headphones
3. Select "Services" (I didn't have Control like the first answer suggests)
4. An interface pops up and shows a list of operations
5. Under list of operations I have Listen to Music
6. I don't exactly remember what the name of the button under Listen to Music was but whatever it is, if you click it, it will do some voodoo and you'll suddenly have your headphones connected and working.

enter image description here

share|improve this answer

To do that click right on the speaker symbol on the right of your task bar and select the playback device tab then you. change your default device from your original one (speakers for me) to your Bluetooth headphones. the good thing is that you dont have to change the default all the time once the headphones are off the sound switch automatically to your speakers.

share|improve this answer

I had the problem too. For me it's because the headset was set to "Handsfree Telephony" only. For windows 7, go to Devices and Printers in control panel. Right click your headset there and click properties. Switch to the services tab and check "Headset" also. This explains why when I started a skype call the headset would suddenly appear but then suddenly disappear later.

share|improve this answer

Under available or hidden icons by the bottom right side of your taskbar in Windows 7, there is a Bluetooth icon where the adapter may have been disabled. Just simply right-click the icon and a box says "Turn Adapter On." May take a few seconds to turn on. Also, the HP Connection Manager could have the Bluetooth feature disabled or turned off.

share|improve this answer

I had exactly the same issue with my Creative WP250 on Windows 7 Pro 64-bit. Right-clicking and selecting "Connect" was totally useless.

Instead:

  1. Go to "Devices and Printers".
  2. Right-click the device icon, and select "Control". A dialogue "Bluetooth Device Control" appears.
  3. Click "Disconnect", then "Connect".

It worked for me.

share|improve this answer

Here's my personal experience with a Dell 375 Bluetooth device on Windows 7 64-bit. I have been wasting my last night installing all kinds of more or less actual and suited drivers in order to get my Bluetooth headset connected to my PC.

The problem: the Bluetooth headset was detected and paired without any problems using the Widcomm stack. However, connecting did not work at all.

Finally I came across the solution: just stopped and restarted the Bluetooth services in the Control Panel. After that the error messages changed and a reboot later the headset connected flawlessly. It's been stable so far.

share|improve this answer

A place to check is Bluetooth settings and be sure Allow Bluetooth devices to connect with this computer box is checked.

This from Windows help:

To control how your computer pairs with Bluetooth devices Click to open Control Panel.

In the Control Panel search box, type Bluetooth, and then click Change Bluetooth settings.

In the Bluetooth Settings dialog box, click the Options tab and do any of the following:

To make your computer discoverable to Bluetooth devices, select the check box for Allow Bluetooth devices to find this computer.

When a Bluetooth enabled computer is in discovery mode, it broadcasts a wireless signal that allows it to be detected by other Bluetooth enabled computers or devices. This is sometimes called pairing mode.

Warning To help protect your computer from someone accessing it without your permission, only make your computer discoverable when you want a Bluetooth device to find your computer. Disable discovery when you no longer need it.

To allow Bluetooth devices to connect to your computer, select the check box for Allow Bluetooth devices to connect to this computer. enter image description here To be notified when a Bluetooth device is trying to connect to your computer, select the check box for Alert me when a new Bluetooth device wants to connect.

The Options tab in the Bluetooth Settings dialog box

share|improve this answer
1  
Thanks for the reply. However, the settings were already set to allow devices to connect to the computer. – Mike Sep 8 '12 at 21:31
    
Reading a bit more on the install it states that there should be an icon on your desktop from which you can click and select to "connect". As it seems it is installed and detected, just not "connecting" a piece of the install has been my focus. I will edit my answer when I find more. – Carl B Sep 8 '12 at 21:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.