Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is a bit of an odd issue: (This is with JRE 7u7 32bit.)

New Lenovo W530 laptop, everything is shiny. I tried to use a java applet for the first time recently (in Chrome). I got the Java logo and it started spinning like it was going to load, but didn't get anywhere and the browser locked up. I tried IE. Same deal. Tried Firefox. Same deal.

So, I did the usual things: Rebooted, nothing. Un-installed Java, rebooted, re-installed, nothing. Tried it installing a 64bit Java as well. Same thing. I tried JRE6. Same thing. I uninstalled and manually deleted all the registry entries I could find related to it, then re-installed. Same thing. I un-installed and used the JavaRa utility. Same exact thing.

I've not been able to use web applets or desktop stuff (minecraft), until yesterday. I did a graphics driver update and I was able to play minecraft for small amounts of time. It crashed regularly and wouldn't start reliably. No change in web applets.

I'm at my wits end here. I'm to the point where reformatting is my only option. If anyone has any ideas at all, that would be awesome.

share|improve this question
This is a real reach, but do you have a restore point that dates back to before Java was installed? That would be a really sure way to undo the broken installation. – Isaac Rabinovitch Sep 9 '12 at 3:39
Sadly, I do not. I'm really not sure it EVER worked. I have no memory of ever needing to use java on this machine. That said, I feel like I would have noticed such a big issue, so it could be new. – Nathan Smith Sep 9 '12 at 5:22
So it was already installed when you first turned on your computer? That suggests that the factory install was screwed up, though it's hard to picture Lenovo screwing up something that badly. Is re-installing your OS an option? – Isaac Rabinovitch Sep 9 '12 at 7:09
I don't really remember if it was pre-installed. And yes, it is an option - that's the last resort reformat I mentioned. The computer has a recovery partition I can roll back to. Unless anyone else has a solution, that's what I'll be doing next weekend. – Nathan Smith Sep 9 '12 at 18:15
If your install is screwed up, your recovery partition might be too. Still, you might as well go ahead. If it doesn't work, try obtaining an install DVD (Microsoft provides ISO images) and installing from that. You'll need the license code for your system -- it's probably on a sticker on the bottom. You'll also need to download and install Lenovo's own drivers and utilities, but before you do that, you should install Java yourself, so that any screwed up Java package Lenovo is providing won't get installed. – Isaac Rabinovitch Sep 9 '12 at 23:07

After you download the installer, don't just open/run it. You must right-click the executable and then navigate your way to where you tell it to "Run in compatibility mode". Vista compatibility mode worked for me, but if you have a "run in XP compatibility mode" that might work too. And while you're there, choose to run it as Administrator.

This worked like a charm for me and I was having the same problem you were.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.