Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Prevent Windows 7 PC from sleeping while a download is in progress

I'm on Windows 7 Ultimate Edition and if I have a large download the computer goes to sleep (and the download is corrupted). How do I prevent it from going to sleep? What I don't get is why does it go to sleep - technically there still is hard disk activity.

share|improve this question

marked as duplicate by Canadian Luke, Mokubai, Nifle, Indrek, Kez Sep 9 '12 at 15:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

3 Answers 3

up vote 0 down vote accepted

Try going into your Control Panel>System & Security>Power options>Change when the computer sleeps and then change your settings so that it never goes to sleep.

I am not too much of an expert, but I think computers just go to sleep based on user input.

share|improve this answer
    
I did that but is there a better way? Now if I forget to turn off my computer (or the download completes) it's just sitting there. –  Celeritas Sep 9 '12 at 1:47
    
@Celeritas What is the source of the download? Like a internet browser? Torrent site? etc. –  Sidd Sep 9 '12 at 1:48
    
Website but I'm using JDownloader. –  Celeritas Sep 9 '12 at 1:49
add comment

Either your downloader has to do it or you have to do it. JDownloader doesn't do this yet so you have to do it manually.

share|improve this answer
add comment

Follow these steps to prevent automatic screen turnoff in windows 7.

1- Click on the power icon in the system tray (beside clock) , and open up the More power options:

enter image description here

2- Under the “Additional plans” section, select High Performance, then “Change plan settings”:''

enter image description here

3- Change everything to “Never”.

enter image description here

4- Click on Save changes button.

share|improve this answer
    
The 'High Performance' plan also sets the minimum processor performance state to '100%' (among setting other non-power efficient settings), so it is not a good idea, IMO, to set it that way. –  galacticninja Jan 2 at 8:07
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.