Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a fresh installation of TextMate 2 the mate command will not install.

The TextMate > Preferences > Terminal > Install button does nothing.

Am I correct in assuming that the mate executable should be somewhere in the app bundle? I think it used to be TextMate.app/Contents/Resources/mate.

I have tried downloading several prebuilt binaries and each fails the same way.

share|improve this question
Have you tried running "locate mate.app" in the terminal? –  Huskehn Sep 9 '12 at 4:06
The 'mate' executable is not likely to have a .app extension, as that is a designation for an application bundle, as far as I know. You can look an /Applications/TextMate.app/Contents/Resources/PrivilegedTool to see an example of an executable that has no extension. Locate mate does not find the file I am trying to find. –  John Sep 9 '12 at 5:57

2 Answers 2

It should indeed be in /Applications/TextMate2.app/Contents/Resources/mate Got my binary from here: https://github.com/textmate/textmate

share|improve this answer

To search for the file, use the following command.

find /Applications/Textmate2.app -name "mate"
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.