Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with font scaling in Win 7. I tried to search but found no apparent solution to this.

About the problem: It manifest itself in older games (from Win 95 era). For example I get this


in "Demise rise of the kutan", and in some other games I don't get any errors but the fonts are completely out of place/alignment/size etc.

Is there way to fix it so that I can run older programs/games?

share|improve this question
Welcome to SuperUser. I edited your question, feel free to revert the changes or edit it again. – Baarn Sep 9 '12 at 12:28
I would suggest running windows 98se in a virtual machine or windows xp. I have had bad luck getting older games like this to work in windows 7. – Phillip R. Sep 9 '12 at 16:20
@Phillip R. it appers that it is the only way :( – NewProger Sep 10 '12 at 11:18
Will stink because you won't be able to do full screen but at least you will be able to play. I have this same issue with star wars knights of the old republic which came out in like 2000. There is a hack to run it on windows 7 but it doesn't run right even if you use it. – Phillip R. Sep 10 '12 at 11:39
up vote 0 down vote accepted

Judging by the dialog picture, it looks like your font scaling (DPI) is turned up above 100% in Windows 7.

So the game is detecting it (since the system for doing so hasn't changed much since Win9x) and is telling you to correct it or else the game will look messed up (or it will choose to not even run).

You can set your font scaling (back to 100%) in Control Panel->Appearance and Personalization->Display:

Display Font Scale

As the SU questions/answers "Set DPI of individual applications in Windows" and "Dual monitors on Windows 7 - How do I set a different DPI or text size on each monitor?" point out, it's a system-wide setting.

share|improve this answer
Yes... that's the problem. I can't use windows with 100%, my screen resolution is too big. So, I'm asking if it is possible to change scaling on per programm basis? So that windows is at 150%, but the program runs at 100%. Is that possible? – NewProger Sep 10 '12 at 4:05
@NewProger Unfortunately, as I said at the bottom of my answer, it's a system-wide setting, and can't be applied per program. – Ƭᴇcʜιᴇ007 Sep 10 '12 at 11:26
Too bad :( Then I guess I will just to forget about these old programs. – NewProger Sep 12 '12 at 3:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.