Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
How do I fix my USB drive to get its original 8GB size back?

Please read this link first

My problem is the same as that described in the question here and I am also using a sandisk usb flash drive 16 GB. However I have no idea how to use bootice. can anyone please help?

share|improve this question

marked as duplicate by KronoS, techie007, Oliver Salzburg Sep 9 '12 at 19:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
-1 please elaborate where you are stuck, have you even tried to use it? –  Baarn Sep 9 '12 at 17:13
    
The answer even links to a tutorial on how to use BootIce… –  Baarn Sep 9 '12 at 17:16
    
I am sorry I wasnt more elaborate. I have downloaded bootice but in the software, I cant understand a single thing. There's something about MBR but I have no experience in this area –  CodeRed Sep 9 '12 at 17:17
    
Please ask specific answerable questions, SuperUser is a Q&A Site, not a forum. Have you read the guide, where did you fail? –  Baarn Sep 9 '12 at 17:23
1  
Instead of linking to the other question and asking to elaborate on the answer, a comment on that answer is the best thing to do. Unfortunately you don't have enough reputation (20) to do that just yet, but after a while you'll be able to do so. Good luck. –  KronoS Sep 9 '12 at 18:17
add comment

1 Answer

Your drive is possibly corrupt and/or defective. I had a similar problem on a drive that I had purchased off of eBay. If your using Windows, I would try following these steps:

(Note: This will remove anything from your drive!)

Go to Start --> Run --> type "cmd" --> Press Enter.

Once the command prompt opens, type "diskpart" then hit Enter. Next you will need to type "list disk" and hit Enter. You will then see a list of disks beginning with Disk 0. Find the disk that corresponds with the usb drive.

For this instance, say the usb drive is disk 1. Type "select disk 1" in the command prompt, hit Enter. You will then see a message that says Disk 1 is now the selected disk. I used disk 1 as just a reference, you need to type the disk number that actually corresponds to the usb drive.

Next, type "Clean" in the command prompt, hit Enter. You should receive a message stating that the disk was cleaned.

Now, type "create partition primary" in the command prompt, hit Enter. You should receive a message stating the specified partition was created.

Now, type "active" in the command prompt, hit Enter. This sets the partition as active.

Now, type "format fs=fat32" in the command prompt, hit Enter which will format the disk.

Now you should be all set with a fresh usb stick with no errors. Once the format completes, the usb stick should work just fine.

Now, just type exit to exit diskpart and then type exit again to exit the command prompt

If that doesn't work, then I am sorry to say but your drive is pouched. Hopefully you can return it to whoever you bought it from.

share|improve this answer
    
Actually it got fixed. There was this option in bootice to repartition the drive. I tried it and now its all fixed. :) –  CodeRed Sep 9 '12 at 17:35
    
Hi @CodeRed. Please state your solution as an answer, so that you can accept it and close the question. –  user3463 Sep 9 '12 at 18:08
    
i cant do that for another 6 hours, thats some restriction they have for the new users. I will do it once the restrictions over! :) –  CodeRed Sep 9 '12 at 18:30
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.