Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I remember my Core 2 Duo E6550's frequency automatically adjusting beyond its stock 2.33GHz speed (to about 2.6GHz if I recall correctly) when my system load was at an appropriate level, but for some reason, it no longer does that. I think it may have stopped doing that when I did a clean install of Windows 7 (from Windows Vista), although my power plan is currently set to performance. I'm pretty sure nothing has changed in my bios relating to processor speed control (my motherboard being an Asus P5QL PRO).

Can anyone tell me why my processor frequency is longer being boosted beyond its stock speed automatically?

share|improve this question
    
What CPU exactly do you have? Intel Dynamic Acceleration was only available in mobile Core 2 Duos, as far as I know. However, the only mobile C2D with a stock speed of 2.33 GHz is the T7600, which doesn't support IDA. –  Indrek Sep 10 '12 at 0:55
    
Sorry for the vague information, I have a desktop E6550. –  TGP1994 Sep 10 '12 at 1:15
    
As far as I can see, that CPU doesn't support IDA. Perhaps you were overclocking it in BIOS or using some software? –  Indrek Sep 10 '12 at 6:28
    
I wonder if that may have been it, too. I may have installed some of Asus's utilities, I'll go and get them again to see if they may have been it. –  TGP1994 Sep 10 '12 at 13:41
    
I gave Asus's utilities a try, no luck (posted results in answer below). –  TGP1994 Sep 10 '12 at 16:36

2 Answers 2

up vote 2 down vote accepted

While some Core 2 Duos can dynamically overclock one core when another is inactive (a feature called Intel Dynamic Acceleration, the predecessor to Turbo Boost), as far as I know it was limited to newer mobile CPUs (Santa Rosa and Montevina generations). Your desktop E6550 has no built-in ability to automatically overclock, therefore you must have been overclocking it manually, either in the BIOS or using some software (either by your motherboard manufacturer or a third-party utility). If you made a backup of your previous Vista installation (or at least a list of installed programs), you can try and check if you had any overclocking software installed.

share|improve this answer
    
Uh oh... This was my first reinstallation where I didn't make an image of the entire drive prior to reinstalling, and I selectively wrote down programs that I thought I would want to reinstall again... Looks like I missed one! Now I just have to remember what... –  TGP1994 Sep 10 '12 at 23:23

Is it possible that your core temps are higher now than they were? for example has the thermal paste been cracked (a small drop can do this) or is your fan blocked at all?

This would stop the system upping the speed if the temp is too high.

Check to make sure that you haven't changed the memory settings to one that is incompatible with the higher clock speed, for example there was a turbo memory setting on my (I think asus) that disabled over clocking.

check vcore voltage, if its too low it may have under-volt protection.

Check that the correct drivers are installed for windows 7 as opposed to windows vista, some kind of lack of communication to the motherboard may be preventing the speed jump

Check the power settings of your performance profile, it may have an advanced setting you have missed.

share|improve this answer
    
With regards to core temps, I don't feel that they're an issue, the temps (with both cores maxed out) range from 55 to 50 degrees Celsius. I think temperatures may have exceeded 60 degrees when the processor's frequency was being changed dynamically. I believe all memory (AI Tweaker tab in the BIOS) settings are set to Auto. VCore voltage is current 1.3V, which I also don't think has changed. I tried installing some Intel chipset drivers from Asus in case that was it, but there was no apparent change after a reboot. I double checked my power settings, everything seems to be at max performance. –  TGP1994 Sep 10 '12 at 13:41
    
In that case it may have been an option on the vista driver that has not been translated over to the win 7 driver or an application that was present on the manufacturers install, some kind of interface program that would have given the fn keys functionality as well as provided the CPU scaling. When you upgraded to win7 this program was not included. Same thing happened on my Asus laptop but with the camera quick keys not working anymore. –  David McGowan Sep 10 '12 at 16:07
    
Even though this is a desktop and not a laptop, I think you may be right, it is beginning to look like some missing software. I've tried installing Asus's utilities, but even still, the clock doesn't exceed stock speeds any more. –  TGP1994 Sep 10 '12 at 16:35
    
perhaps a bios update may provide some more functionality... its worth a try –  David McGowan Sep 10 '12 at 16:47
    
That would make sense, although I already have the latest BIOS. –  TGP1994 Sep 10 '12 at 18:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.