Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want Chrome to open all .html files. It is currently set as my default browser, however html files open in IE9. When I go to Control Panel\Programs\Default Programs\Set Associations I see that .html and .htm files are associated with IE. When I choose to change the default program it I'm presented with a list of programs but Chrome is not one of them. I browse to, and then select the Chrome.exe (C:\Users\Matt\AppData\Local\Google\Chrome\Application\chrome.exe) but it goes right back to IE. This is the first time I've seen anything like this. I'm running Windows 7 64 bit. I never had this problem on Windows 7 32 bit.

Is this because Chrome by default installs in the User directory, not the Program Files directory?

How can I fix these file associations?

EDIT: It's not that things are reverting back to IE after associating them with Chrome. When I browse to Chrome in the file association window, and select it, it doesn't seem to take. It doesn't show Chrome in the list of programs despite pointing to the Chrome.exe location. I really think this has something to do with the fact that it doesn't install into the Program File Directory.

share|improve this question
    
Can you try installing FireFox and seeing if you can make it the default browser to open HTML files, this will help rule out if it's just specific to Chrome or specific to IE restoring the association? –  Nick Josevski Sep 10 '12 at 0:22
    
Did you try registering Chrome as the default browser using Chrome itself? It should register itself as the default handler for those files. –  Synetech Sep 10 '12 at 0:28
    
How are you determining that Chrome is set to be your default browser? Just becuse Chrome says so doesn't make it true. There are Registry entries that must be made - is anything preventing that, for instance antimalware apps, environment freezers, etc.? –  kreemoweet Sep 10 '12 at 0:39
    
@NickJosevski Firefox is already installed and it does give me the option to associate html files with Firefox. –  matt Sep 10 '12 at 1:25
    
@kreemoweet I chose to make it the default browser when prompted to by Chrome. It is also listed as the default browser in the windows Default Programs list under browser. It just isn't the default, or even an option under the file associations section. –  matt Sep 10 '12 at 1:27

4 Answers 4

up vote 3 down vote accepted

Some of the settings may have changed after you installed Chrome and set it as the default browser (for example, some other program may have registered itself as the handler for HTML files).

Unfortunately, Chrome’s make default browser function is disabled because it thinks it already is the default browser because it only checks one or two of the various relate settings.

You can work around this by using another browser’s make default browser function, followed by Chrome’s make default browser function. That should allow Chrome to re-register itself as the handler for .htm* files.

You can do it with IE since it comes with Windows, but you have Firefox, so you can use that.

share|improve this answer

If the standard

Right click on file

Open With > Choose default program...

Select Chrome

Doesn't work, try:

  • To recreate the issue with with either Firefox or Opera.
    • This may then help move the default opening file from Firefox/Opera to Chrome
  • Do a restore defaults in IE
    • Internet Options > Advanced > 'Reset Internet Explorer Settings' > Reset...
    • This may help bring IE back to a state where it won't interfere with your changed associations
  • Re install Chrome
    • Worth a try (possibly try switching from main version to beta version, or vice versa)
  • Try this as another user on your system (create a new user if need be)
    • Sometimes Chrome user settings get corrupted.
share|improve this answer
    
I believe OP already did and that did not work for him. The changes were somehow reverted. –  Darius Sep 10 '12 at 0:17
    
Cheers Darius :) –  Nick Josevski Sep 10 '12 at 0:29
    
I haven't tried reinstalling Chrome yet. I'll do it tomorrow. –  matt Sep 10 '12 at 1:52

From within Chrome, click on the wrench icon next to the address bar, then select "Settings". You should see an option for making Chrome your default browser.

share|improve this answer
    
As I said, it already is. –  matt Sep 10 '12 at 1:44
    
You said you chose to make it the default during the installation and by various other means. If you also tried doing it through the wrench icon and settings, I don't see where you said that. –  Nicole Hamilton Sep 10 '12 at 2:03
    
Sorry. To be clear. In Chrome it says: "The default browser is currently Google Chrome" in Windows under "Choose a default browser" Chrome is selected. –  matt Sep 10 '12 at 17:34

Looks like IE is registered for the Open verb for this file type in your system. Either change your system associations or setup a custom association in the settings of FileZilla.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.