Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm on a Mac running Snow Leopard with the old/free version of MacFUSE and NTFS-3G. I have one external harddrive that was pre-formatted in NTFS and mounts itself with fusefs, so everything's great. I just added a 2nd hard drive that I repartitioned and formatted in Windows XP with ntfs, which my mac mounts using a read-only ntfs driver.

Why are the drives being mounted differently, and how can I get the new one to use ntfs-3g?

Thanks!

(Here's the output from a mount command, if it's relevant)

/dev/disk2s1 on /Volumes/OldDrive (fusefs, local, nodev, nosuid, synchronous)
/dev/disk1s1 on /Volumes/NewDrive (ntfs, local, nodev, nosuid, read-only, noowners)
share|improve this question
2  
Figured it out, actually: Short answer: running a simple chkdsk /f in Windows on the incorrectly-working drive fixed a number of errors and allowed the drive be mounted correctly in OS X. Longer answer: manually calling ntfs-3g on the drive (i.e. sudo ntfs-3g /dev/disk1s1 /Volumes/MountPoint) gave a better error message. – MrTransistor Sep 10 '12 at 6:22
1  
Could you post your solution as an answer? You can then (after a brief wait) "accept" it as correct. It would help future answer-seekers :) – JoshP Sep 10 '12 at 14:00
up vote 0 down vote accepted

Short answer: running a simple chkdsk /f in Windows on the incorrectly-working drive fixed a number of errors and allowed the drive to work correctly again.

Longer answer: Manually calling ntfs-3g on the drive (i.e. sudo ntfs-3g /dev/disk1s1 /Volumes/MountPoint) gave me a much better error message--one that told me to run chkdsk in Windows!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .