Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows 8 Professional, Metro Apps and Windows Update do not work with static IP settings behind authenticated proxy server. They work with DHCP on the same proxy settings (we have DHCP for wifi and static IP for LAN, both using the same proxy server).

IE, Chrome and other desktop apps work nicely with both.

Metro apps worked with an auth proxy (DHCP only), when I changed their proxy settings from the "edit group policy" option:
Start → Settings → Edit Group Policy → Computer Configuration → Administrative Templates → Network Isolation → Internet Proxy for Apps

How can I fix this?

share|improve this question
    
I don't know the answer, but you shouldn't start questions with "Win 8 professional Metro apps". It looks like spam. –  Mr Lister Sep 10 '12 at 6:32
    
What exactly is hostels? –  Ramhound Sep 10 '12 at 10:59
    
@Ramhound Hostels=student residential buildings on campus. Irrelevant, I made the question more general. Basically I meant to say that we have to use DHCP in some places and static IP in other places with the same proxy--if it's working with DHCP but not with static, then there's obviously some issue stemming from the static IP. –  Kamal Sep 13 '12 at 14:42
    
Hmm.. static IP also requires you to setup all different settings (Gateway, ...) as well. Are those the same? DNS, WINS, Subnet.. I am having similar problems right now, though. –  Andreas Reiff Oct 18 '12 at 8:55

1 Answer 1

up vote 1 down vote accepted

configured a loopback proxy using ccproxy link. Thanks...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.