Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to log into my FC16 VM, I end up on the Filesystem repair prompt.

I am guessing this is an issue caused by the corruption of the filesystem.

In this filesystem repair prompt, I am unable to run most of the commands. Most of the files are also in read only mode.

First thing is that I want to know the type of my Filesystem - is it ext2, ext3 or ext4??

For that if I do a "df -T", it says that it doesn't recognise df command.

If I simply run fsck, this is all I get:

(Repair filesystem):# fsck
fsck from util linux 2.20.1
(Repair filesystem):#

Upon reboot I end at the same repair filesystem prompt again.

What is the way out of here??What are the commands that I can run here in the repair filesystem prompt?

TIA - Sidharth

share|improve this question
    
Did you ever figure this out? –  Damainman Apr 30 at 21:20
add comment

1 Answer

Depending on the version of Linux, you may have been given the specific fsck command to run in the text displayed prior to entering the (Repair Filesystem) shell. The root filesystem is mounted read-only to prevent further damage and to permit repair.

Take a look at /etc/fstab (/bin/cat /etc/fstab), find the root ('/') filesystem entry. The device to check is in the first column, something like /dev/hda1 or /dev/rootvg/root. The filesystem type that is expected is the third column.

For example, if the root entry on your system is:

/dev/rootvg/root      /      ext3     defaults  1 1

Run the following to attempt to repair the root filesystem:

/sbin/fsck /dev/rootvg/root

If fsck can't figure out what the filesystem type is, you can tell it what to expect by adding the -t option, as shown here.

/sbin/fsck -t ext3 /dev/rootvg/root

After repairing the root filesystem, you may want or need to repair more filesystems. If so, just run the command again for each filesystem that you are checking.

Don't forget to replace '/dev/rootvg/root' with your system's device and 'ext3' with the expected filesystem type from /etc/fstab for that filesystem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.