Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

One of my users has the following issue in Outlook 2003:

When she creates a new message with her signature automatically appended, the text direction is right to left as it should be (all the relevant settings are Hebrew and right to left, except for UTF8 encoding).

When replying to html emails with the signature automatically inserted, sometimes the text is set to Hebrew, aligned right, direction right to left. Sometimes the text is set to English, aligned left, direction left to right. In particular, I found two emails from the same sender, both with the sender's text in Hebrew on the right, where replying to one would lead to Hebrew as editing language, and to the other English as editing language, both with their respective correct directions and alignment. The one that switched to English, was a forwarded message. In all cases, the signature itself appeared correctly, it were the default language, direction, and alignment of the to be inserted text before the signature that were wrong in one case and right in the other. When leaving the signature out (at least not automatically inserted), both were set to Hebrew with the correct alignment and direction.

I tried recreating the signature anew to no avail. When opening the signature using advanced editing options, in Word, I did see that there is a body tag in the signature, which has also set lang=EN-US. However, changing this to HE and direction=RTL, did nothing to fix the issue.

It seems that this came from interaction from the probably faulty html of the message and the probably faulty html from the signature, but is there some way to fix this? In other words, to tell Outlook to ignore whatever weird html there is in the body of the received message, and to just make sure that the editing language is set correctly?


share|improve this question

You must log in to answer this question.

Browse other questions tagged .