Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed the dokuwiki via apt-get. The first call to http://localhost/dokuwiki give me "403 Forbidden" as response:

Achtung! HTTP/1.1 403 Forbidden
You don't have permission to access /dokuwiki on this server.

In the log filee (/var/log/apache2/error.log) i found following:

client denied by server configuration: /usr/share/dokuwiki/

I don't have an idea, what is really wrong. So i've tried this:

sudo chmod -R 755 /usr/share/dokuwiki
sudo chown -R www-data:root /usr/share/dokuwiki

but the problem was not solved. Any ideas?

edit:

https.conf is empty, here the output

-rw-r--r-- 1 root root 0 Mai  2 21:11 /etc/apache2/httpd.conf

and the /usr/share/dokuwiki/.htaccess looks good (imho):

## Enable this to restrict editing to logged in users only

## You should disable Indexes and MultiViews either here or in the
## global config. Symlinks maybe needed for URL rewriting.
#Options -Indexes -MultiViews +FollowSymLinks

## make sure nobody gets the htaccess, README, COPYING or VERSION files
<Files ~ "^([\._]ht|README$|VERSION$|COPYING$)">
    Order allow,deny
    Deny from all
    Satisfy All
</Files>

## Uncomment these rules if you want to have nice URLs using
## $conf['userewrite'] = 1 - not needed for rewrite mode 2
#RewriteEngine on
#
## Not all installations will require the following line.  If you do, 
## change "/dokuwiki" to the path to your dokuwiki directory relative
## to your document root.
#RewriteBase /dokuwiki
#
## If you enable DokuWikis XML-RPC interface, you should consider to
## restrict access to it over HTTPS only! Uncomment the following two
## rules if your server setup allows HTTPS.
#RewriteCond %{HTTPS} !=on
#RewriteRule ^lib/exe/xmlrpc.php$      https://%{SERVER_NAME}%{REQUEST_URI} [L,R=301]
#
#RewriteRule ^_media/(.*)              lib/exe/fetch.php?media=$1  [QSA,L]
#RewriteRule ^_detail/(.*)             lib/exe/detail.php?media=$1  [QSA,L]
#RewriteRule ^_export/([^/]+)/(.*)     doku.php?do=export_$1&id=$2  [QSA,L]
#RewriteRule ^$                        doku.php  [L]
#RewriteCond %{REQUEST_FILENAME}       !-f
#RewriteCond %{REQUEST_FILENAME}       !-d
#RewriteRule (.*)                      doku.php?id=$1  [QSA,L]
#RewriteRule ^index.php$               doku.php
share|improve this question
    
This is related to your Apache HTTPD configuration. Two things to check are: /usr/share/dokuwiki/.htaccess file and the <Directory> clause in the httpd.conf file. –  Yedric Sep 10 '12 at 12:57
add comment

1 Answer

up vote 2 down vote accepted

I have found a solution:

In the /etc/apache2/sites-available/default i put following:

    <Directory /usr/share/dokuwiki/>
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
    </Directory>

If you are migrating from other machine, then you need to copy the data folder to /var/lib/dokuwiki/

sudo cp -r ~/data /var/lib/dokuwiki/

after that i changed only the permissions for the data folder:

sudo chmod -R 775 /var/lib/dokuwiki/data
sudo chown -R www-data:www-data /var/lib/dokuwiki/data

Now is my dokuwiki working fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.