Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Debian install (Linux machine 2.6.32-5-686 #1 SMP Sun May 6 04:01:19 UTC 2012 i686 GNU/Linux) is limited to 1360x768, but my monitor is capable of 1680x1050. There is no xorg.conf file so I created one using

Xorg -configure

Here, I added the resolution lines as described in many google resuts; I added the line

Modes     "1680x1050"

under each Display subsection, then I copied this to /etc/X11/xorg.conf. I rebooted the computer however 1680x1050 is not listed in the list of available resolutions. Ive also tried adding a more complete list ie

Modes     "1680x1050" "1360x768" "1024x768" "800x600" "640x480"

But the result is the same.

Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath   "/usr/lib/xorg/modules"
FontPath     "/usr/share/fonts/X11/misc"
FontPath     "/usr/share/fonts/X11/cyrillic"
FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath     "/usr/share/fonts/X11/Type1"
FontPath     "/usr/share/fonts/X11/100dpi"
FontPath     "/usr/share/fonts/X11/75dpi"
FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath     "built-ins"
EndSection

Section "Module"
Load  "dri"
Load  "dri2"
Load  "record"
Load  "extmod"
Load  "dbe"
Load  "glx"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option      "Protocol" "auto"
Option      "Device" "/dev/input/mice"
Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Device"
    ### Available Driver options are:-
    ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
    ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
    ### [arg]: arg optional
    #Option     "AccelMethod"           # [<str>]
    #Option     "DRI"                   # [<bool>]
    #Option     "ColorKey"              # <i>
    #Option     "VideoKey"              # <i>
    #Option     "FallbackDebug"         # [<bool>]
    #Option     "Tiling"                # [<bool>]
    #Option     "Shadow"                # [<bool>]
    #Option     "SwapbuffersWait"       # [<bool>]
    #Option     "XvMC"                  # [<bool>]
    #Option     "XvPreferOverlay"       # [<bool>]
    #Option     "DebugFlushBatches"     # [<bool>]
    #Option     "DebugFlushCaches"      # [<bool>]
    #Option     "DebugWait"             # [<bool>]
Identifier  "Card0"
Driver      "intel"
VendorName  "Intel Corporation"
BoardName   "82915G/GV/910GL Integrated Graphics Controller"
BusID       "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
    Viewport   0 0
    Depth     1
    Modes     "1680x1050"
EndSubSection
SubSection "Display"
    Viewport   0 0
    Depth     4
    Modes     "1680x1050"
EndSubSection
SubSection "Display"
    Viewport   0 0
    Depth     8
    Modes     "1680x1050"
EndSubSection
SubSection "Display"
    Viewport   0 0
    Depth     15
    Modes     "1680x1050"
EndSubSection
SubSection "Display"
    Viewport   0 0
    Depth     16
    Modes     "1680x1050"
EndSubSection
SubSection "Display"
    Viewport   0 0
    Depth     24
    Modes     "1680x1050"
EndSubSection
EndSection

Have I missed something obvious? I tried to get the HorizSync and VertRefresh values using ddcprobe, but the edid output from ddcprobe says edidfail. There doesn't seem to be a definitive way to set the resolution in linux and I don't want to set up an xrandr script to run each time I log in - I want to set it the 'proper' way. Thanks

EDIT: I have solved it by doing

> cvt 1680 1050 60
# 1680x1050 59.95 Hz (CVT 1.76MA) hsync: 65.29 kHz; pclk: 146.25 MHz
Modeline "1680x1050_60.00"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync

and placing this line in the Monitor section. Why should I have to do this when a google search suggests otherwise?

Also how can I set the login screen resolution? While the user's resolution is set to 1680x1050, the login screen resolution is still 1024x768. Google searches suggest setting the desired login screen resolution as the first resolution in the Modes list, but this has no effect.

share|improve this question
    
If you have answered your question, would you consider writing it up as an "answer" instead of merely an update to your question. You can then accept the answer as correct. It will help future answer-seekers :) Also, if your answer has opened up a new line of questioning, you may get more attention by creating a new question specifically tailored to the new issue. –  JoshP Sep 10 '12 at 14:09
add comment

1 Answer

up vote 0 down vote accepted

I have solved it by doing

> cvt 1680 1050 60
# 1680x1050 59.95 Hz (CVT 1.76MA) hsync: 65.29 kHz; pclk: 146.25 MHz
Modeline "1680x1050_60.00"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync

and placing this line in the Monitor section. But I dont know why I need to use a Modeline instead of Modes.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.