Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows installation has Latin and Cyrillic inputs enabled, but uses the English layout.

And I suddenly realized that non-unicode programs can not display Cyrillic symbols. They are displayed as ?.

So it seems that my codepage became broken or something... I believe it should be Windows-1251. But I don't know/remeber is there a global codepage settings? Maybe somewere in registry? I would prefer to not reinstall the OS.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

If anything else fails, you can try to dive into

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage

  • ACP is the default ANSI code page

  • OEMCP is the default OEM code page

  • MACCP is the default Macintosh code page

share|improve this answer
    
Thank you, it helped. –  Imaskar Sep 10 '12 at 22:58

is there a global codepage settings exist?

Start -> Control Panel -> Clock, Language and Region -> Region and Language

Choose the Administrative tab, there is a section subtitled Language for non-unicode programs, click the Change System Locale … button.

The system locale determines the default character set (letters, symbols, and numbers) and font used to enter and display information in programs that don't use Unicode. This allows non-Unicode programs to run on your computer using the specified language. You might need to change the default system locale when you install additional display languages on your computer. Selecting a different language for the system locale doesn't affect the language in menus and dialog boxes for Windows or other programs that do use Unicode

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.