Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While running Ableton Live 8 after a project gets to a certain size, the audio starts to get a bit choppy and distorted. My levels are fine and is not the cause of the lag and chop.

I have samples set to 1024 and the high quality button selected which I need to hear the sound. I always lower these when I'm recording audio with my mic but I need to have these turned up to be able to mix master the song.

Anything I can do to lower the CPU usage? It sucks because I can't even use my iZotope Ozone plug-ins because of their CPU usage and they are AMAZING plug-ins that I would love to use.

EDIT

just upgraded to 6GB of Ram and SSD 500GB Intel Core Duo 2 Processor 2.26 ghz

I thought this upgrade would have fixed the problem but it hasn't. Ableton says CPU is maxing out 80-100% CPU usage and I don't believe this should happen.

share|improve this question
    
What do you mean lower your CPU usage. I would just make the project smaller. If this is not an option its time for an upgrade. –  Ramhound Sep 10 '12 at 15:28
    
I literally just upgraded... –  Travis Dtfsu Crum Sep 10 '12 at 15:44

1 Answer 1

up vote 4 down vote accepted

In Ableton Live you can do the following to lower CPU usage:

  1. "Freeze" tracks that use VST or AU plugins - select the track you want to freeze, right click on it, and choose Freeze Track. This will render the track to an audio file, but you can always unfreeze it and make changes to your plugins.

  2. In the Preferences menu, Audio tab, under the Latency heading, increase the Buffer Size. This will increase your latency when recording, but for mixing and mastering it shouldn't be a problem. You mentioned you have it set to 1024 samples, in Ableton Live 8 running on my 2007 Macbook it goes all the way up to 2048 samples. I believe the maximum buffer sample size is determined by the driver you are using for audio playback. I am using CoreAudio and the built in output on my Macbook.

  3. In the Preferences menu, Audio tab, under the Sample Rate heading, make sure this is set to 44100 for the lowest CPU usage.

  4. If you are warping tracks, try using Complex as opposed to the Complex Pro warp setting. You can always change it back to Complex Pro before exporting the project to your finished audio file.

  5. Setup bus tracks for plugins to route multiple audio tracks through if you are using the same plugin with the same settings on multiple tracks.

share|improve this answer
    
thanks for the advice! I will have to freeze stuff more often I guess. But I only have one problem with your answer. In my preferences the sample rate only goes up to 1024... why doesn't it allow me to go up to 2048? This doesn't effect songs when they are exported does it? My exported sounds sound really good right now. –  Travis Dtfsu Crum Sep 10 '12 at 16:19
1  
I added some more info to my original answer, I think it is determined by your audio driver. Increased buffer size will not affect the exported audio. Thanks for the rep, on a side note I have been using a 2.0Ghz Core2Duo Macbook with Live for quite a few years now, it is really easy to max out the CPU on a full production, but with freezing tracks it can be done. We really should be using computers with quad-core i7 processors for audio production though. –  Chad Pranke Sep 11 '12 at 5:19
    
Ah ok that makes sense. I thought using a midi-interface would improve the audio processing capabilities, but guess not. –  Travis Dtfsu Crum Sep 11 '12 at 15:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.