Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A couple of days ago, I started being unable to connect to, which handles logins to all kinds of google services.

I get this error in Chrome:

Error 126 (net::ERR_SSL_BAD_RECORD_MAC_ALERT): Unknown error.

enter image description here

In IE I get this:

enter image description here

I assume it is the same error, just wrapped up.

I run Win8 RTM.

On the SAME machine, using the same network card, in a VMWare workstation image running Win7, I am able to connect perfectly. On another of my machines on my network, I am also still able to connect with no problem.

My girlfriend uses the same network and has also complained a couple of times about this error (google calendar) - but this is anecdotal, since her technical troubleshooting abilities stop at "xxxx is broken". Her machine runs Win7. ;)

I have rebooted, cleared cookies, do not run any antivirus/firewall, have not changed network config. The first 3-4 days after installing Win8, I did not have any problems.

I have also searched, and found a hint about enabling SSL2.0 in connection settings, which did not help.

Anybody know something about this error and what I can do to fix it?

I blogged about the problem and setting MTU on the computer here.

share|improve this question
I've found this while googling: change MTU to 1400 in router settings.. Have you tried that? – m4573r Sep 10 '12 at 15:28
I don't have access to fiddle with my router. And I have used this same router for 6 months. – Kjensen Sep 10 '12 at 15:30
Try doing a low level wireshark capture of the entire conversation (filter by hostname for and try to see what's wrong. Also, see if you can find a description of ERR_SSL_BAD_RECORD_MAC_ALERT in the OpenSSL source code.. Might be able to figure this thing out – allquixotic Sep 10 '12 at 15:36
Wireshark is not compatible with Win8 - or to be more precise - WinPCap refuses to install under Win8. – Kjensen Sep 10 '12 at 18:45
up vote 1 down vote accepted

I read some russian forum posts that suggest that setting the routers MTU to 1400 might also fix it.

Translated with Google!

A little ways down the page it says: decision of badguy: >blah< mtu 1400 router >blah<

You might also try setting your primary or secondary DNS server to (google's DNS) and you can adjust your MTU on your PC if you can't get into the router settings.

share|improve this answer
Do you have a source? The way that this answer stands, this is more of a comment than an answer. – KronoS Sep 11 '12 at 16:42
Setting MTU on the computer did the trick. Both on my own Win8 box and my GF's Win7 laptop, that started having the same problem. My landlord recently changed a switch we connect through, and I think this must be related. – Kjensen Sep 13 '12 at 16:45
Awesome! Glad it is fixed! – d4v3y0rk Sep 13 '12 at 17:18

I had the same problem. According to this forum post, there are two ways to deal with that:

There are two ways to solve this problem:

  1. Upgrade firmware for your router. You may download the last version of firmware from website of the manufacturer of your router.
  2. Change "MTU" value to "1400" in your router settings. This option is located in "IP Config" -> "WAN & LAN"
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.