Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two Crucial M4 128GB SSDs. They were in a RAID0 array, but the array no longer exists and I need to check each of them to see which one is bad, if either (could have been the controller, who knows).

What installed, Windows sees them as the 256GB RAID0 array, even with only one connected. I cannot initialize it, no matter what I try. It is write-protected, so EaseUS can't do anything with it either.

Intel Rapid Storage Technology software shows it as it's correct size (119GB I think), but that software doesn't actually DO anything...

I tried using the Windows 7 install to format one, but it doesn't even show up as an installed hard drive.

I'm out of ideas and at a complete loss.

share|improve this question
add comment

1 Answer 1

The easiest way is to first turn fake RAID off in the BIOS (change IRRT to AHCI). Then boot from a CD and wipe/reformat the drive.

There are quite a lot of bootable CDs which will do this. Some with a familiar windows interface (e.g. Hirens, Sysutils ERD commander). Some with a different OS (quite a lot of GNU/Linux live CDs).

You could even boot DBAN to completely wipe the disk. The goal of DBAN is to completely wipe drives. Just make sure it is the only drive in the computer. Link to DBAN.

share|improve this answer
    
SATA mode is set to AHCI already in the BIOS. I can't believe this is the only way to wipe the drive :( Thanks for the input though! –  Greg-J Sep 10 '12 at 22:54
    
I ** suspect** that there is one sector on the drive marking it as part of a RAID array. If you could find that one and wipe it all would be solved. But I got no idea how to do that with windows. (FreeBSD has a 'shoot in foot mode' which disables all those checks for already mounted drives. Makes things a lot easier, and has the potential to really mess things up if you make a typo. But I am not going to recommend a another OS just for wiping. :) A live CD should work fine and is a lot simpler. ) –  Hennes Sep 10 '12 at 23:00
    
Which of the live CDs would you recommend for this? –  Greg-J Sep 10 '12 at 23:04
    
I would try DBAN because it claims to a secure erase command to the disk. For a SSD this is a good way of wiping all data. Failing that I would use something I actually used before, which in my case is ERD commander (now taken over by microsoft). If you have a plain windows install DVD then you can also try to boot that into the recovery console and do a disk clean. That should wipe the beginning of the disk, but I am not sure where the extra RAID data is. Typically it is stored at the beginning OR the end of a disk. –  Hennes Sep 10 '12 at 23:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.