Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My son just re-installed Windows XP, but for some reason Windows isn't recognizing that there is a network card. In Device Manager, there is no entry for the item, even though an inspection of the motherboard shows that there is an ethernet port, and its LED is lit with the cable plugged into an active broadband connection.

This is an on-motherboard networking "card", btw. Unlikely to go missing.

The thing was working previously, there was no hardware problem at the time of the re=install.

Any ideas?

Edited to Add: This turns out to be an IBM ThinkCentre PC.

share|improve this question
    
there is no "Unrecognized" device in the Device Manager? –  Logman Sep 10 '12 at 23:02

2 Answers 2

up vote 1 down vote accepted

The ThinkVantage System Update App will assist. Download and run and it will likley identify the missing driver(s). Failing that, enter the system model code and grab the driver directly.

share|improve this answer
    
Yep. Found the network card driver there. Using another PC of course, since the network card wasn't working on the target machine. Heh heh. The exact model number wasn't there, but a little searching finally paid off. –  Cyberherbalist Sep 11 '12 at 0:11

Fresh install, download the builtin network driver from the motherboard manufacturers website and install it. If you posted the motherboard make/model I could probably give you the link to the driver.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.