Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 8 Enterprise x64 (RTM), and I cannot figure out how to disable to the lock screen that appears after the computer has been idle for 10-15 minutes.

I've tried the following, and none of them work:

1) Disabling Screen Saver "display logon screen" option.

screen saver options

2) Disabling the Power Plan "require a password" setting.

power plan settings

3) Changing the lock screen policy:

policy settings


None of these disable the lock screen, it still appears after 10-15 minutes. The only setting that has any affect at all is changing the policy (#3 above), but it merely disables the Welcome Screen image (the one that you click/drag/type on to get to the lock screen). But you still end up at the lock screen and have to re-enter your password.

Short of disabling the user login completely, is there any way to disable the lock-on-idle setting in Windows 8?

share|improve this question
    
Does it happen to be a trial version? Has this happened ever since you installed it? Are you using a local account or an online account? Are you on a domain? –  imtheman Sep 12 '12 at 18:38
    
Thanks for your response! It's the RTM version (downloaded through my MSDN account), but RTM is essentially the "final version," so no, it's not a trial version. Yes, it's been happening since I first installed it. I'm using a local account, and I am not on a domain. –  Michael Sep 13 '12 at 22:46
    
I wonder if that's some default Win8 Enterprise "feature" because it doesn't happen to me on Win8 Professional. –  imtheman Sep 13 '12 at 23:03
    
Yeah, I was beginning to think the same thing. Thanks for the feedback. –  Michael Sep 14 '12 at 17:24
    
No prob. If I find anything out about that I'll post it, but for now I think you might be out of luck. –  imtheman Sep 14 '12 at 20:50
show 1 more comment

7 Answers

This may help you to keep your Computer awake all the time. So, there will be No Idle time and apparently no Lock Screen!

enter image description here

share|improve this answer
3  
Thanks for your response. Unfortunately, my computer is already set to never sleep. Apparently it's not sleeping that's causing the lock screen. –  Michael Sep 11 '12 at 2:46
add comment

If the Group Policy Editor did not help, I think the only way out is to completely disable password entry at logon:

  1. Type netplwiz at the Start Screen, and launch the app that comes up

  2. Select your user account and uncheck Users must enter a user name and password to use this computer

  3. You'll be prompted to enter your password twice

  4. Now just restart and you should be both password and lock screen free

share|improve this answer
    
Thanks for your response. Unfortunately I already had this setting unchecked. This appears to be a problem with Windows 8 Enterprise only. –  Michael Oct 27 '12 at 0:09
    
Completely disabling password entry is not the most secure way to work on your computer I think :-) –  Dennis G Jan 6 '13 at 14:26
add comment

Hopefully, the following setting will apply both when waking from sleep and from with the idle lock. Maybe not, though; I don't have Enterprise to test it. (That is a big problem though! Microsoft should do something about it.)

Try using Windows 8's new settings menu:

Go to the Settings menu: Go to the Settings menu

Click "Change PC Settings": Click the Change PC Settings button

Click the "Users" button, then the button that says "Any user that has a password must enter it when waking this PC". Waking lock disable?

Accept the confirmation. The setting will be changed. Confirmation/Warning Dialogue

share|improve this answer
1  
Unfortunately, this option is disabled (greyed out) in Windows 8 Enterprise, with a message saying that the group policy does not allow changing the setting. Thanks for your response, though! This is useful information for other versions of Windows 8. Upvoted. –  Michael Oct 31 '12 at 0:30
    
Ah, sorry. (I checked it in Pro and it does work there.) Thank you very much. –  WindowsEscapist Oct 31 '12 at 0:55
add comment
up vote 2 down vote accepted

After hours of frustration trying to figure this out, I finally discovered the solution. The problem seems to stem from the fact that I'm using Windows 8 Enterprise. (At least I think. I'm not sure why else these obvious solutions weren't working.)

Apparently, by default Windows 8 Enterprise's security settings disable or override all of the solutions mentioned in the other responses (and original question).

Here's the solution:

Go to:

Control Panel > User Accounts and Family Safety > User Accounts

And choose this item in the list on the left:

Reset security settings

Once you reset your security settings (and reboot), you will be able to disable the lock screen.

Disclaimer: I have no idea what other settings are changed by clicking Reset security settings, but this problem was enough of an annoyance for me that I wasn't concerned. Your mileage may vary.

Source: http://answers.microsoft.com/en-us/windows/forum/windows_cp-security/computer-is-timing-out-to-lock-screen-and-requires/b8bb769d-c714-42a9-9e6a-ef7a1ec80121

share|improve this answer
1  
Glad to see you got it fixed! –  WindowsEscapist Oct 31 '12 at 0:56
    
Didn't work for me - still showing the lock screen after idling even if disabled in group policy. Also on Win8 Enterprise –  Dennis G Jan 6 '13 at 16:18
1  
Once you've reset your security settings (as described above), try disabling the lock screen via the new Metro Start Screen, like this: superuser.com/a/496223/86764 If that still doesn't work, then I would go through all of the other settings (e.g., all three described in my original question at the top of this page) and make sure you have the right settings in all of those places too. I'm not sure exactly which setting did the trick, but I know I had to "Reset security settings" first. –  Michael Jan 7 '13 at 23:18
add comment

Windows 8 Pro User

It took me forever to figure this out, but I had to go through the 'Local Group Policy Editor' to prevent the screen lock.

-Search for 'Group Policy' under settings.

-Once in the Local Group Policy Editor you will find 'Logon' under 'Administrative Templates' > Systems > Logon.

-Right click and select 'edit' on 'Allow users to select when a password is required when resuming from connected stand'

-Enabling this options fixed the problem for me. Hope this helps!

share|improve this answer
    
It is not working for me. –  skiabox Sep 26 '13 at 20:28
add comment

Disabling it is simple but not particularly straight forward at first:

Go to the Desktop > Control Panel > User Accounts, and click Reset Security Policies on the left hand side.

share|improve this answer
add comment

For Windows 8 PRO the correct solution is the following : (The above windows 8 pro solution is not working for me)

Control Panel --> System and Security --> Power Options --> Require a password on wake-up

And in the next screen click Change settings that are currently unavailable --> Don't require a password --> Save changes

share|improve this answer
    
This was the only method that worked for Win 8.1 Pro with Media Center –  Ben Wilson Jan 9 at 2:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.