Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I'm running KDE settings, in kttsmgr.

I go add Talker, and try to add a swift talker:

/opt/swift/bin/swift -p "speech/rate=180" %t -o %w

..per the instructions here, which I suspect are out of date.

But when I go OK, it says invalid talker and wipes the settings.

How can I make Text to speech in KDE use the cepstral speech engine ?

share|improve this question
Does that command work from the command line (if you replace %t with the text and omit -o %w) – Paul Sep 11 '12 at 3:09
yes, but of course you have to change the %w to a file name to write to like tmp.wav .. and %t to the text you want to speak out loud. I thought it might be the "speech marks" but removing that part didn't help. I think that the latest kde needs some api backends rather than just allowing shell commands. – matiu Sep 11 '12 at 6:41

You must log in to answer this question.

Browse other questions tagged .