Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old Pentium 4 system (Abit IS7 series motherboard) running XP. The machine is set up as an HTPC. It was set up and running well for years with 1 SATA drive as a boot drive, another SATA drive to store TV recordings, and an IDE drive to store more recordings.

Last week the original boot drive (a Seagate SATA drive) failed after 8 years of almost continuous uptime. The BIOS would no longer recognize it, and I did not have an OS installed on either of the other two drives, so the machine could not boot. I had a disused Western Digital 80Gb IDE drive hanging around, so I used my Windows install CD to reformat it and install XP on it.

My two IDE hard drives (the "new" Western Digital 80Gb with XP on it and a Western Digital 250Gb with no OS) are now on one channel. I set the jumpers according to the diagrams on the drives, so that the boot drive is master and the data drive is slave.

I have two SATA connectors on the motherboard, so the remaining healthy SATA data drive (a Samsung 500Gb) is plugged into SATA1. (In the BIOS settings it shows up as IDE Channel 3 master.) I have set the boot order in the BIOS so that the IDE drive with XP on it has top priority.

All three drives are recognized by the BIOS, however the system will only boot if I disconnect the healthy Samsung SATA data drive. I am sure the Samsung 500Gb SATA drive is functional, because if I hot plug the drive AFTER the system is booted, I can go into the control panels and mount the drive, and see all the files and folders on it in Windows Explorer.

Any suggestions on what is going on and how to fix it? Many thanks.

share|improve this question
    
Are you sure your original boot drive is broken? Maybe it is just the bios which can't handle sata on start up (anymore). Did you try to hot plug the former boot drive to see what it does? –  Mixxiphoid Sep 11 '12 at 6:02
    
Yeah, I wondered whether for some reason the on-board SATA capabilities on the motherboard got disabled. However when I started working the problem originally, I left both of my SATA drives plugged in and ONE of them (the data drive) WAS recognized by the BIOS. –  Kevin Sep 11 '12 at 14:01
    
Does the board have an option to let you select the boot device manually? For example, during the POST, can you press something like F8 to access a boot-device list to choose what to boot from? If so, then try manually booting from the IDE drive while the SATA is plugged in. If it works, then it is likely to be an issue with the BIOS boot/drive settings. If it does not, then it may be the IDE drive’s boot configuration data (try using the XP disc to re-install the boot-record while the SATA drive is plugged ing). –  Synetech Sep 11 '12 at 17:09
    
Also try changing the SATA mode (OnChip Serial ATA setting) from Auto⇨Enhanced⇨Combined (page 3-13 in the manual). –  Synetech Sep 11 '12 at 19:08
    
Did you try an alternate SATA mode? –  Synetech Sep 13 '12 at 18:20
show 1 more comment

4 Answers

If you can set it in you BIOS and it boots without the SATA drives, probably for IDE / PATA hard drive has No Jumper present (which means it's on Slave Mode) or it's set to a Jumper which is on Master without Slave present / Master with non ATA compatible Slave.

Change the IDE drive jumper to Single or Master. Attaching a screenshot below:

Jumper Settings


Update:

Some links I promised with people having similar problems, but most say they can't boot through the SATA when IDE is connected. Your problem is exactly the opposite.

I simply think the BIOS has some issues, and sadly Abit has stopped making motherboards and has also stopped giving updates. You might need to find a decent workaround!

share|improve this answer
1  
Just a brief note: These jumper settings can differ per manufacturer. –  Hennes Sep 11 '12 at 14:00
    
@Hennes : I know, the diagram was just for an example. I did not mention anywhere that he should set it to the a particular numbered pin! –  aliasgar Sep 11 '12 at 14:03
    
Thanks for this. I was under the impression that with SATA you did not have to set jumpers? Maybe some additional detail on my setup would be useful. My two (working) IDE hard drives are both one on channel. When I added the new boot drive to that channel, I did set the jumpers according to the diagrams on the drives, so that the boot drive is master and the other slave. My second IDE channel has only the DVD drive on it. I have two SATA connectors on the motherboard, so the SATA drive is plugged directly into that. –  Kevin Sep 11 '12 at 14:07
    
With SATA you do not have to set additional drivers. (1 device per channel solves that). With P-ATA/IDE you do have to set single/master/slave. If these are set incorrect then weird things happen. Especially when windows 'helpfully corrects' the issue and the BIOS does not, or vice versa. --- @aliasgar: I thought it best to state that explicitly. –  Hennes Sep 11 '12 at 14:09
    
@Kevin : I can give you more details if you tell me the make of your motherboard and hard drives. And you can plug them in 1 by 1 so you can test if are achieving the boot sequence you want! –  aliasgar Sep 11 '12 at 14:12
show 10 more comments

to have your ide drive boot before your sata is quiet simple you have to have your first ide drive set up as master and your cd/dvd drive as slave plug your sata drives into chanel 0 or 1 depending on you motherboard, Then after you have the hardware side done you have to go into your bios and select the master ide drive to first boot and your sata to second bootable drive. Turn on your system and your computer will boot to your xp os then you do all your formatting on your sata drive. After all that you change your sata to first boot and install windows 7 on the sata let it load and install. After installation is complete you can go into your xp drive and get all you files of there and transfer them to you sata and then format the IDE drive.

Thanks for reading hope this helps

Patrick

Patricks A+ PC Repairs

share|improve this answer
add comment

If the previous answers have not helped, you may want to check your CMOS battery and see if it needs replacement.

share|improve this answer
add comment

SOLUTION:

You need another HDD. Unplug the "broken HDD" and boot your computer with a new HDD. Enter BIOS Setup and disable LBA. Turn OFF computer. Connect again your "broken HDD" and it will boot.

In my case the OS from "broken HDD" was also unavaileble... so after boot i've got this message: "Error loading operating system". So i reinstalled Win 7, enable LBA form BIOS Setup and thats it. But if you want to keep the original OS... you need to boot from that new HDD and enter in an OS from that HDD. With diskmgmt.msc from Run you have to set your old system drive as active. after that.. reboot from "broken HDD". It should work...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.