Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm not sure if this is the proper place to ask this question.

Here is my issue

I'm using windows 7 and i have installed Zope Server.(Zope is python web framework which has a built-in server). I can connect to this server from my browser by typing,

localhost:8080

But if i try to connect this server from another machine using my IP or even from my own system it doesn't work. ie

xxx.xxx.xx.xxx:8080
share|improve this question
1  
what are the contents of your ipconfig /all –  Keltari Sep 11 '12 at 7:02
    
You can try changing address 127.0.0.1:80 in your zope.conf to 0.0.0.0:80 (port number depends on your port-base) –  Gene Sep 11 '12 at 7:08

1 Answer 1

up vote 3 down vote accepted

This sounds like an issue with your firewall. In windows, please open port 8080.

  1. Open Control Panel from the Start menu.

  2. Select Windows Firewall.

  3. Note: If Windows Firewall is not available, change View by to Large icons at the top right of the Control Panel window.

  4. Select Advanced settings in the left column of the Windows Firewall window.

  5. Select Inbound Rules in the left column of the Windows Firewall with Advanced Security window.

  6. Note: You can prevent outbound traffic by selecting Outbound Rules.

  7. Select New Rule in the right column.

  8. Select Port in the New Inbound Rule Wizard and then click Next.

  9. Select which protocol this rule will apply to (TCP or UDP), select Specific local ports, type a port number (8080) (or port numbers (8080,8081)).

  10. Select Allow the connection and then click Next.

  11. Select when this rule applies (check all of them for the port to always stay open) and then click Next.

  12. Give this rule a name and then click Finish to add the new rule.

  13. The port is now open and ready to be used.

Although typically, the local port to use is port 80.

share|improve this answer
    
Well spotted. I read it as 80 as that's what I always use. Thanks, edited my answer. –  Dave Sep 11 '12 at 8:18
    
It worked. Thanks... –  Optimus Prime Sep 11 '12 at 8:30
    
It's a pleasure. –  Dave Sep 11 '12 at 8:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.