Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a sound file in my app that the iPhone does not play. After checking other problems I checked the file permission in terminal.

What I can see is that the file permission of this file has a- @ at the end of it. I don't know if that is the problem but this is the only difference from the other sound files that plays fine.

  1. What is this sign ?
  2. Could it cause a problem ?

EDIT

Thanks

this is what I get:

com.apple.FinderInfo:
00000000  4D 34 41 20 68 6F 6F 6B 00 00 00 00 00 00 00 00  |M4A hook........|
00000010  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  |................|
00000020

Thanks Shani

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The "@" sign (which is not documented in the manual page for ls) indicates that the file has extended attributes. You can use the command xattr -l <filename> to show them.

As for how to read it, this is a representation of the structure of the hexadecimal data:

struct finder_info {
    char[4] filetype; // x,y coords of top left corner for directories
    char[4] creator; // x,y coords for bottom right corner for directories
    char[2] finder_flags;
    char[2] finder_loc_v;
    char[2] finder_loc_h;
    char[2] opaque1; // Icon ID?

    char[2] scroll_position_v;
    char[2] scroll_position_h;
    char[2] reserved1;
    char[6] opaque_finder_flags
    char[2] reserved2;
    char[2] putAwayFolderID;
};

To solve your problem, I have found this workaround:

On your Desktop, use Finder to make an empty new folder, and name it Foo.

While holding the option key, drag the video files into the Foo folder. This copies rather than just moves the files.

Then, in Terminal, enter the following lines, one at a time:

cd ~/Desktop
cp -XR Foo NewFoo
cd NewFoo
ls -@l

Are the @ signs gone? Can you open the files now?

share|improve this answer
    
Thanks @m4573r Edited my question, how do I read it ? –  shannoga Sep 11 '12 at 9:34
1  
Hey. I simply deleted this data with xattr -c <filename> and it works great now. Thanks For you help. –  shannoga Sep 11 '12 at 12:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.