Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I assigned keyboard shortcut Cmd-. to "Zoom" a window for all applications, it works fine except for Mozilla Thunderbird, I guess that is because Thunderbird has a menu item View -> Zoom -> Zoom in (out, reset, etc.). How to assign a keyboard shortcut to do that? Thanks.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

You could specify nested menu titles like >Window>Zoom on 10.7, but it stopped working on 10.8.

You could also use an application like Moom or BetterSnapTool or assign a shortcut to an AppleScript that clicks a zoom button.

share|improve this answer
    
I assigned Ctrl+Cmd+. to >Window>Zoom for Thunderbird and I see it appears in the right menu item, however it does not work either in 10.7.4. I see enough information to solve this in other way. Thank you! –  mattw Sep 13 '12 at 2:12
add comment

In System Preferences > Keyboard. Click the Keyboard Shortcuts tab. In the left hand pane, at the bottom, there is a "Application Shortcuts" item. Choose that, and you'll see a new pane on the right and a "+ / -" control. You'll need to click the "+" and choose Thunderbird as the application, and then type in the exact menu item you'll want to activate with the defined keyboard shortcut.

Here's an example I use for VLC: enter image description here

enter image description here

share|improve this answer
    
Thanks for the detailed step, my question was about shortcut for nested menu item, @Lri answered that quite well. –  mattw Sep 13 '12 at 2:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.