Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm an avid user of Chrome and would defend it to the death but there is no denying that it has issues, and I've been experiencing a lot of them recently.

Issues

  1. Stuck tabs

    Issue: Around 60% of the time (higher when the system has just started), when Chrome is launched, some or all of the pinned tabs and startup pages will get stuck in the counter-clockwise-rotating "contacting server" mode and never snap out of it.

    Stuck tabs

    Fix: Quit and launch Chrome until they load properly (this really isn't good, as quitting and launching Chrome can and has cleared all pinned tabs).

    Extra Information:

    • If you stop the loading and re-enter the URL then the page will load perfectly.
    • The amount of pinned tabs or startup pages seems to be irrelevant, but I could be wrong.

     

  2. "Downloaded/out of"

    Issue: Each item in the download bar has a downloaded status section, formatted as "downloaded/out of". Sometimes Chrome doesn't display the "out of" part.

    Downloaded/out of

     

  3. Collapsed settings windows

    Issue: In Chrome version 19(ish)+, settings are configured via overlayed / popup windows. Sometimes, the window will open fully collapsed.

    Fix: Resize Chrome's window or open the developer tools.

    Collapsed settings windows

  4. "Network Error" with large downloads

    Issue: Sometimes, when downloading large files (500MB+) Chrome will download the entire file, the download status will freeze (for example, "1 GB/1 GB") for a few minutes, report "Network error", and delete the .crdownload file.

    "Network Error" with large downloads

    Extra Information: The same file from the same website on the same computer downloads perfectly in other browsers. The website and file type seem to be irrelevant.

 

Information:

  • I've experienced some of these issues on my home PC and some on my work PC, both of which are Windows 7 Ultimate x64. The only things that link them are my Google account (all settings are synced).
  • Updating Chrome hasn't worked. Most of these issues presented themselves around about version 17 and have continued right through to 21 (current).
  • Uninstalling Chrome, deleting all data in %programFiles(x86)%\Google and %localAppData%\Google, and reinstalling hasn't worked.
  • I have yet to see whether disabling all extensions would make a difference, but it's hard to diagnose as these issues don't occur 100% of the time.

 

In my case, I don't know if there's an actual solution. I'm just curious as to whether anyone else is having similar issues to those that I'm experiencing. At least then I'll know it's an issue with Chrome itself.

share|improve this question
    
Re. issue #4, is there a particular reason you use Chrome to download large files such as linux distros? I understand that torrents are preferable. Also, I'm not sure that Chrome has a "resume download" feature. –  user151227 Sep 11 '12 at 15:33
1  
It was the only freely- and easily-available, legal large file that came to mind, that's all. –  mythofechelon Sep 11 '12 at 15:40
1  
It would probably be better to have these as four separate questions. –  Al E. Sep 12 '12 at 13:34
add comment

2 Answers

up vote 2 down vote accepted

You have network issues and data corruption.

  1. Get yourself a new clean profile, make sure you don't synchronize it with Google and stop using software like CCleaner (it breaks it down). If you don't want to really stop it, you could opt to deselect Google Chrome in it and instead clean your cache through Google Chrome itself. Or rather, set the settings right and just don't care...

  2. Then inspect chrome://net-internals and fix your computer's network.

  3. To inspect browser start problems, pass --log-net-log=C:\blah.txt as CLI parameter.

share|improve this answer
    
#1 Network issues and data corruption on two separate PCs after a hard reinstall? Seems unlikely.. #2 As stated in my post, I've already tried creating a new profile. #3 I don't use software like CCleaner. Why would you assume that I do? –  mythofechelon Sep 11 '12 at 14:20
    
@BenHooper: If the two PCs are in the same network then it's highly likely; but that's not even necessary, you told yourself that you linked them thus propagating the problem between both. Furthermore, you could try out different versions (earlier stable, stable, beta, dev, nightly) to see whether they act the same. I didn't assume it, I recommend not to do so. –  Tom Wijsman Sep 11 '12 at 14:24
    
My work PC and home PC are not on the same network. Yeah, I may try some dev releases, but, also stated, the issues have persisted since version 17(ish), so I don't know what level of success I'll have. –  mythofechelon Sep 11 '12 at 14:26
1  
@BenHooper: Can you please create a new clean profile and not sync it with the corrupted profile? Your level of success is quite high, because this bug isn't there for everyone but only a small group. –  Tom Wijsman Sep 11 '12 at 14:26
    
@BenHooper: What about the network troubleshooting, anything noticeable there? Do you have a log that we can look at? –  Tom Wijsman Sep 11 '12 at 14:34
show 3 more comments

In my case, I don't know if there's an actual solution. I'm just curious as to whether anyone else is having similar issues to those that I'm experiencing. At least then I'll know it's an issue with Chrome itself.

Discussion questions are not the best fit for SU. However, I think the question is answerable in the sense that it's four binary questions: for each of the issues you experienced, are they known defects in Chrome, or are they something specific to you.

  • Issue #1 is something I experience on a daily basis. I don't know the reason why this happens, but I can only reproduce it on Windows. On Linux it works fine. I would be surprised if this issue manifests for every user of Chrome under all circumstances on Windows; that would be a fairly major bug. So there must be some underlying reason for it happening, something about our systems that is common. Chromium Issue Tracker has an "Assigned" bug about this, but it's hard to know if this is precisely the same issue as we are experiencing. Read some of the comments though.

  • Issue #2 is not a real bug. This is simply due to the fact that some HTTP servers don't supply the Content-Length: HTTP header in their HTTP response, or they provide an invalid Content-Length, like 0 or -1. Chrome can't possibly know how big the file to download is if the remote server provides an invalid size. Also possible is that the server may say the Content-Length is smaller than the actual size of the file, or larger -- both of these situations can confuse Chrome.

  • Issue #3 I'm not sure about, I haven't seen that one before.

  • Issue #4 looks to be specific to your internet connection, as I've never seen this after running Chrome on three platforms across many versions and different PCs and connections. It may literally be what it says and could be related to your network connection.

P.S. -- The strongest possible answer to this question would be a link to a bug report for each valid issue. I've done that for the first issue, but I wasn't able to find an issue report for #3 or #4. #2 is not a valid issue so you should not be searching for a solution to it; no solution exists, even in principle.

share|improve this answer
    
Issue #1 has to do with CCleaner's incorrect cleaning, which is why I've chosen to avoid that piece of software ever since. The reason people on Linux don't experience this is because they don't break down Chrome's folders, and I didn't experience this bug anymore after I stopped using CCleaner long time ago. –  Tom Wijsman Sep 11 '12 at 14:17
1  
I have never installed CCleaner (or any software even remotely serving the same purpose as it) and I experience issue #1, so while CCleaner may indeed cause this issue, it appears not to be the only cause. –  allquixotic Sep 11 '12 at 14:20
    
Issue #2 and #4 are correct and are not bugs. Issue #3 is a similar story to #3 which is again due to incorrect cleaning; it's not the window being to small, it's the incapability to properly read out the cache folder. A better error message could be useful, but why deal with bad changes caused by other software. –  Tom Wijsman Sep 11 '12 at 14:20
    
Hmm, if you haven't installed CCleaner this might have to do with corruption, but it's hard to actually prove that unless you were to write an actual application that checks the integrity of the files. And then another thing to wonder is where that corruption would come from, best way to check is to create a new profile... –  Tom Wijsman Sep 11 '12 at 14:22
    
When I get home to the PC where I have reproduced Issue #1, I'll try moving/renaming my old profile, reinstalling Chrome from scratch (including deleting its folder) and test for Issue #1 again. I'll let you all know. –  allquixotic Sep 11 '12 at 14:26
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.