Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows, I need to use a key (RSA-2) generated from puttygen in "SSH Secure Shell" software v.3.2.9. The s/w has a key import option, and it asks for the .pub file. I tried importing the .pub file (exported as openssh from the puttygen), but it is having problem opening it. I've also tried pointing it to the exported private key, but it's the same result

share|improve this question

migrated from stackoverflow.com Sep 11 '12 at 23:15

This question came from our site for professional and enthusiast programmers.

    
What you are importing is puublic key id_rsa.pub, you need private key in PUTTYGEN which may be named as id_rsa! –  Mayur Pipaliya Sep 11 '12 at 1:22
    
Why aren't you saying what error you get? Is it a secret? –  stark Sep 11 '12 at 2:38
    
It says unable to load key file. –  Yun Sep 11 '12 at 3:21
    
Is the private key not the one received when we go to menu Conversions, Export OpenSSH keys? I expected to import the private key too, but when I press Import in "SSH Secure Shell", the default is that it's looking for *.pub files. I can force to select the private key, but when I connect to a remote, the SSH says "Failed to read your public key file C:\....." –  Yun Sep 11 '12 at 3:25

1 Answer 1

SSH uses id_rsa and id_rsa.pub (private and public keys, respectively). Not all implementations of ssh are truly compatible in reading each other's keys, right? This is where an extra step may be helpful. On the Solaris 10 server I connect to, I have my key pair in my .ssh directory.

I originally file copied these to my Windows box and imported to SecureSHell 3.2.9, but when I tried to use them I got the same complaints about not being able to read/load the key file. Back at my Solaris machine, I ran ssh-keygen -e -f id_rsa.pub > exportkey.pub, copied this to Windows, and tried to import with SecureSHell. Finally, I told SecureSHell to delete all the keys I had been working with and create a new RSA key. Then I exported and uploaded this key back to my Solaris box. I was not paying close enough attention, as it created a .ssh2 directory with an authorization file containing a pointer to the name of the public key, and of course the public key itself.

On the Solaris box, I did an ssh-keygen -i -f .ssh2/pubkey.pub >> .ssh/authorized_keys. Now I can login to the Solaris machine from either puTTY or SecureSHell without a password.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.