Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a cross functional work flow in visio 2003 with 6 horizontal swimlanes. I am trying to select multiple processes that are on top of the swimlanes, however, when trying to drag a selection area around them with the pointer tool (i.e. just left-clicking and dragging) it moves the swimlane that is underneath rather than starting the selection box.

To get around this I am having to ctrl + left click every process that i want to move, but is not feasible as the document gets bigger.

Thus far google

Any help would be greatly appreciated

share|improve this question

If I understand what you're doing, you should be using the "Groups" function in Visio.

So, after creating your multiple processes, manually select them (CTRL-left click), and then place them all into a group by selecting: Shape --> Grouping --> Group. (Or CTRL-SHIFT-G).

As you add more and more processes, you can individually add each new process to the group you created (in the above step) by selecting the new process and the group (by selecting any one item in that group) and then selecting: Shape --> Grouping --> Add to Group.

Once your group has been created, you can move the entire group as one object rather than each individual new object (process).

share|improve this answer
This solution does not really work in the context off rapidly adding new shapes, have multiple shapes in multiple groups, and having up to 100 shapes in a group. many thanks for the help, but i think this serves as more of an addition to the work around, but not a solution – BiGXERO Sep 12 '12 at 1:58
up vote 0 down vote accepted

So i discovered how to do it.

You need to protect the background shapes (in this case the swimlanes) from being selected, so that when you left click on the shape, instead of Visio activating the shape like it normally would, it ignores the shape and acts as if you were just clicking an area of blank page, essentially turning the swimlanes into the background, allowing you to draw the selection box arount the object that are

To do this:

  1. Right click the swimlane > format > protection
  2. Tick the 'From Selection Box'
  3. Press 'Ok'
  4. Go to View > Drawing Explorer Window
  5. In the new window that has appeared, right click the document path (the bit that starts with C:\ or whatever drive you are using) > protect document
  6. Ticks 'Shapes' > Ok
  7. The shape that you originally selected should no longer be selectable.
  8. To reverse this, untick 'Shapes' from the protect view.

You can apply this to multiple shapes at once by holding control when you originally select the shapes that you want to protect.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .