Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a T410 with an nVidia NVS 3100M, this is not a hybrid system, there is no Optimus. (No option in the BIOS for Optimus, lspci in linux as well as the Windows device manager only show the nVidia)

Using lspci I see the GPU as a present device, however, I can not, for the life of me, get any video driver to work that will let me start an X session, every time X craps out with the error (EE) No devices detected.

I have tried the nVidia binary blob, (with nvidia-config, made sure no nvidia support in the kernel), I have tried nouveau, I have tried nv, I have even tried generic vesa, nothing will work.

When I compare the dmesg that I get when loading the nvidia kernel module, I see that it is missing some lines compared with another system that also has an nvidia card, specifically the line mentioning the GPU name (3100M) is not there.

I have checked every option in the BIOS, there is nothing to control except for the BIOS video output port, which is set to the LCD panel.

I have no idea anymore what the problem may be, or even how I can diagnose this problem further. Any help will be appreciated.

share|improve this question
Sounds weird. The card should run perfectly with any recent GNU/Linux release. Maybe it's a hardware fault which you don't experience under Windows. – Shiki Sep 12 '12 at 5:18
It is weird indeed, but if something as fundamental as being detected by the driver is caused by a hardware fault I really would expect to see a similar problem in Windows, of course with nVidia being the closed shop it is I don't really have any way to check, short of replacing the laptop... – wich Sep 12 '12 at 5:24
Uhm Lenovo got a great warranty. Chances they can replace it locally at the service area are high. My laptop got replaced in 30 minutes. If you still have a warranty on it, that's your best shot. Bring a live Linux USB/disc with yourself. If you got now warranty, just use Windows and VMware 9. It's got 3D acceleration too. Don't get me wrong, I do want to help. – Shiki Sep 12 '12 at 5:26
The problem is that I would first have a corporate IT organization to get through; in short, not going to happen. – wich Sep 12 '12 at 5:28
Have you tried upgrading your BIOS to the latest version? Usually on ThinkPads, this also takes care of Video Card ROMs. You just may hit a bug here. A T410 should work just fine running Linux with X. – gertvdijk Sep 12 '12 at 7:36
up vote 0 down vote accepted

For those ever encountering a similar problem, the cause turned out to be the lack of a /sys mount point, many thanks to airlied @ freenode#nouveau

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.