Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For years I have been cloning the main drive on my MacBooks to make bootable external drives. This way I have a (reasonably) up-to-date, bootable, portable external drive that I can plug into any mac and boot off of for what reason (e.g., the main drive failed and I need to restore).

Yesterday, this failed with the error given in the title.

The configuration and procedure: A MacBook Pro (early 2011) with 8 GB RAM, Lion (server). The main drive is 750 GB

This is a pretty standard MacBrook Pro configuration.

The external drive is a 2 TB LaCie. The hookup is Firewire 800. The LaCie is partitioned into 2 partitions: 1. Boot => 750 GB 2. Data RAID Set Backup => 1.25 TB

Everybody is formatted HFS+

The LaCie was formatted using SoftRaid 4.3.3

  1. Reboot and press the option key to get list of bootable devices.
  2. Choose to boot off the Lion recovery disk
  3. Choose to enter into Disk Utility
  4. Use "Restore" on MacIntosh HD. MacIntosh HD is source and "Boot" is the destination.
  5. Hit Restore. And in this case get the above error.

Anybody else seeing this? I googled around and saw one case where someone saw this error - but they were working with Boot Camp (so that is a difference) and moreover I'm not sure that the question that was asked was actually answered.

TIA!

share|improve this question

migrated from stackoverflow.com Sep 12 '12 at 5:26

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Okay, I've experimented a bit and tried out several different new "workflows" and have one that works in this case. Here is it - it's very simple.

Use the same disk utility for both formatting and partitioning the destination disk that you use for the restore itself (in this case the disk utility on the Lion recovery disk). That's it.

In detail:

  1. Restart, press option key. Boot into Recovery disk. Choose Disk Utility.
  2. erase and partition the destination disk. Must be GPT (GUID partition Table)
  3. restore the main boot drive to new boot partition on the destination disk.

If you (like me) use SoftRaid, you can convert to SoftRaid after you created the new back boot disk.

I do not know why partitioning using the disk utility or SoftRaid utilities on the normal boot drive (which is just an updated version of Lion, after all) would fail with their error and perhaps it is just a peculiarity of my system).

Regardless, other than being a time-waster this problem did not end up being a showstopper. If for whatever reason you encounter this problem while cloning your main boot drive in your laptop, just try using the same disk utility for both formatting and partitioning the destination disk that you use for the restore itself and I think you'll avoid this sort of annoying problem.

share|improve this answer
    
If you use the same OpenID for your SU account as your SO account, and link them, you'll get ownership of this migrated question. –  Daniel Beck Sep 21 '12 at 13:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.