Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My PC doesn't sleep anymore, and it did used to.

I can't imagine what's changed (I did swap the SATA cables for my two HDDs around - but could this cause it?)

I've been in Device Manager going through the options and unchecking "Allow this device to wake the computer" from everything, and I've also unchecked all of the Wake on LAN options from my NIC (Intel 82579V Gigabit Network Connection) in this section too.

I've unplugged each of my peripherals (Wacom, Microsoft Keyboard, Logitech mouse, Lacie USB 3.0 external HDD, any USB sticks, no CDs in drive, but every time I press sleep, it returns me to the Log in screen (as if it went to sleep and immediately awoke).

I've exited the server for Unified Remote, and exited FileZilla server.

Is there anything else which could prevent a sleep?

Thanks

-- Win 7 Ultimate 64-bit, asus p8z68-v, Core i5-2500k, 16gb corsair, 500gb 5400rpm, 500gb 7200rpm (OS), gtx 570

--

Edit: I've run "powercfg -energy" and tried to sleep - the report is here http://pastebin.com/ZeGUa34n which shows that the USB hubs didn't power down, but I've no idea how to solve that :(

Edit2: as Dave Rook notes in his answer below, sometimes powercfg will flag errors which aren't related to the issue. In my case, changing sleep mode to "Hybrid" solved the issue, and I didn't need to investigate the USB hub further.

share|improve this question
    
A few years back my third party application firewall prevented sleep on XP. Maybe something like that is still running? –  Daniel Beck Sep 12 '12 at 9:44
    
I've actually stopped using my software firewall - and this issue might date back to when I got my new router; I'll try disconnecting the eth cable and sleeping. -- edit: but no such luck –  ataulm Sep 12 '12 at 9:50

1 Answer 1

up vote 2 down vote accepted

Since you've been through so much, I assume it must be a configuration issue (or maybe a conflict). Before we look into that, there are a few things to try:

All troubleshooting should start by inspecting Microsoft's Event Logs. In the case of Windows 7, begin by clicking Start, then type event. Once you launch 'View Event Logs, review the Critical Errors in the last 24 hours. Follow-up by looking in the Windows Logs and filtering the System Log for 'Kernel-Power' entries. Interesting items would include 'The last sleep transition was unsuccessful', or 'The system is entering sleep'.

Power Options

I am willing to bet that 60% of all Sleep and Hibernate problems are due to inappropriate settings in the Power Options (Control Panel, Hardware and Sound). For example, if you see no Hibernate option on the Shutdown menu, then check whether 'Allow hybrid sleep' is set to 'on'. You could start this line of troubleshooting by pressing the Windows key +x on a laptop, or Start Search, powercfg.cpl on a desktop. See screen shot of Allow hybrid sleepCertified for Windows 7 logo

Does the Bios Support Sleep Mode?

Provided the computer has the 'Certified for Windows 7' all the power management features are guaranteed to work. It's just up to you to configure Sleep or Hybrid Sleep, or else complain to the supplier / manufacturer.

To check your computer's Bios you need to interrupt the initial boot phase. For this inspection, seek a special key, it maybe F2, or maybe spacebar, it could even be the delete key. If all else fails read the boot screen! Once you have intercepted the bios boot, just carefully examine any options which could enable / disable Sleep. What you are looking for is settings such as,

S3 - Suspend to RAM (Sleep)
or
S4 Suspend to Disk (Hibernate)

Idea: See if there any updates for your BIOS. If so a later version may cure your sleep problems.

How to Stop Your Computer from Going to Sleep (or to see if it has been told to not sleep)

1) Navigate to the 'Power Options' (Start Search powercfg.cpl) or see above.
2) Select your power plan.
3) Click: Change plan settings.
4) Crucial Links:
a) Change advanced powers settings.
b) Change settings that are currently unavailable.
5) Research the myriad of settings, in particular: 'Sleep'
6) Expand: 'Sleep after'. If it's a laptop check both the 'Plugged in' and the 'On Battery' settings.
7) Choose: 'Never' to prevent your computer going into sleep mode.

Windows 7 Hibernate Problem: Windows 7 Hybrid Sleep (No Hibernate Option)

There are at least two different types of hibernation problems. One problem is that your computer is not waking up properly. Alternatively your problem is there is no Hibernate option on the Windows 7 Shut Down menu. In both cases check the 'Allow hybrid sleep' setting.

1) For any hibernation problems the easiest solution is to set 'Allow hybrid sleep' to: 'Off'.

By design, hybrid incorporates both Sleep and Hibernate, thus you only see Sleep on the Shutdown menu. Also, by default, desktops are set to 'Allow hybrid sleep :On'.

Trap: Before you can change any of the Balanced settings, first you must click on Change settings that are currently unavailable.

2) Another problem with hibernation is caused because Windows 7 does not have enough free disk space for hiberfil.sys. My machine needed 4 GB, the size of my RAM.

3) An over-active Disk Cleanup program may cause the Hibernate option to disappear. If Hibernate does not appear on the Shutdown menu, then open a command prompt and check with: Powercfg -q

If this was your problem, for future reference you could remove the tick next to 'Hibernation File Cleaner' in the Disk Cleanup settings.

Next turn on Hibernate with: Powercfg -h on

3a) Check for errors with: Powercfg -energy

Incidentally, Powercfg -energy gave me errors and warnings - even when the computer awoke from sleep gracefully. However, the point is that the information in the html report may point you to which devices need further investigation and driver updates.

Source

share|improve this answer
    
+1 for exhaustive answer. Sleep now works (I turned Hybrid "off"). Thanks for your time and effort :) –  ataulm Sep 12 '12 at 10:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.