Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am experiencing this issue over and over again and I just cannot seem to find the answer. It doesn't make sense, but search simply does not return results from folders that certainly have these files inside. It's weird that this technology exists for more than 5 years now (it could be added to Windows XP as an addon), and they still haven't got it right.

My folder contains 10 image files with .png extensions. Two scenarios:

  1. Scenario 1: I exclude the folder using Indexing options. Search works.

  2. Scenario 2: I turn on indexing for this folder. Search does not work.

Of course, Agent Ransack returns results every time. When I check Advanced options for the Indexing options inside control panel, .png files are checked in the File Types tab, using the "File Properties filter".

What's the deal with this?


To clarify, this doesn't happen with all folders, but does with more than one. For the "problematic" folders, even *.* doesn't return a single result. I found some advice to clear the archive and readonly attributes for all files (doesn't make sense, but hey), but it didn't work.

Indexing status in Control panel is: Indexing complete. 100,000 items indexed. Folder is included in the list. File types list contains the .png extension (although it doesn't work with any filter, not even *.*).

share|improve this question
Did you try rebuilding the index completely? – Moab Sep 12 '12 at 21:01
No, but I'll try. Although it's a pity, because right now it says "Indexing complete. 100,000 items indexed." It's going to take a while until it's rebuilt, but what the heck. – Lousy Sep 12 '12 at 21:31
Its strange, mine works very well most of the time, but every now and then it does not return a file I know I have and can navigate to, it just did it to me, so I closed explorer windows and opened a fresh one (i assume it cleared some sort of cache, and wallah it found it, windows search has always sucked. – Moab Sep 12 '12 at 21:56
up vote 2 down vote accepted

Are you giving the indexing service time to index the files? This can take time. If you enable indexing and it doesn't work immediately, that seems like a sign to me that files are not yet put into the index. Search is searching the index, not finding the files, then thinking they don't exist.

When you turn off indexing, search is iterating through the folder and thus finding the files.

After you enable indexing, give your computer some time to index all your files. You can see progress in the "Indexing Options" dialog (search in Start for it).

If you still have problems:

  1. Open "Indexing Options"
  2. Ensure folder, or parent folder is listed there (and not excluded)
  3. Click Advanced.
  4. Approve UAC
  5. Under File Types tab, make sure the file extensions you want are selected.
  6. Back under Index Settings tab, look under troubleshooting, select "rebuild" and approve.
  7. Give the computer time to index. If you use the computer, Windows automatically slows down indexing so let it run overnight. The more files you have, the longer it will take.
  8. Try again and let me know if you're still having problems.
share|improve this answer
Actually, this folder is indexed for a long time, I did the mentioned test with a different folder just to confirm that it's an indexing problem. Indexing status is "indexing complete", so it's not working anymore. But the whole presumption that search shouldn't work while indexing is in progress doesn't make any sense, because it should (by design, probably) fallback to a recursive disk search. And the thing is, I don't see this problem with all folders. Some of them are being searched well for any criteria, while some fail to return a result even if I set *.*. – Lousy Sep 12 '12 at 21:30
Oh screw it, I turned off indexing completely. I have an SSD so searches are pretty fast anyway. – Lousy Sep 13 '12 at 9:20
Did you try rebuilding the index? That's always worked for me. Watch out though on SSD--it works fast for filename searches but does not search within the documents themselves. – EntropyWins Sep 13 '12 at 22:08
I really don't want to use a solution which in not reliable. This is my 2nd Windows 7 installation, and I had this problem on Vista and my other Win7 PC also. This time I also ran the "Indexing troubleshooter" as suggested by Windows, and it found no problems with the index. If rebuilding would change the outcome, then they really have no control of their search system. And Agent Ransack searches both filenames and contents. – Lousy Sep 14 '12 at 12:54
I can't speak for Vista, I too found the experience with search poor. I haven't had issues with Windows 7 though. You mentioned having a SSD. Did it come with a tuning wizard that turned off the search service? I know Samsung's SSD Wizard recommends this, even though it is a crap suggestion on newer drives. Look for it in services.msc – EntropyWins Sep 14 '12 at 13:07


PROBLEM: I was having the same issue where the Explorer window would only display search results when the Windows Search in Services was stopped. Furthermore, some folders allowed explorer search, while others displayed no results. Needless to say, Windows 7 Explorer search was not working.

Here's one solution that I stumbled on for Windows Search in explorer, etc...

SOLUTION: Click "properties" for the parent folder in question (Google Drive for me), click the Security tab and make sure SYSTEM is one of the user names allowed. If it's not, click Edit and add SYSTEM. After, I opened Indexing Options and clicked Rebuild. Solved!

CREDITS: This is not my discovery. Here is the full answer from Joel who did all the hard work figuring it out. Thank you so much Joel! Windows 7 Index Search does not work in Google Drive folder

share|improve this answer
This fixed my problem, except I had to recursively add SYSTEM permissions to all files and folders in the folder that wasn't indexing. – Heptite Jan 26 '15 at 23:39

I tried this simple modification and worked like a charm. Got this from some genius named Thekid2point0 on another site:

"Not sure if this would help but I had a user with this same issue and after awhile changing all the settings I could find, I found one that did the trick. Under the Folder options go to the Search tab and under how to search check the "Don't use the index when searching in file folders for system files" check box close windows explorer and then reopen and try your search again. This worked for me hopefully this will help someone else out there."

share|improve this answer
Hello Shawn, do you have a link to go with the information-just as an extra reference-thanks – mic84 Jul 7 at 0:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .