Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently upgraded from Team Foundation Server 2010 to 2012 and Visual Studio 2010 to 2012.

Within Visual Studio 2010 I can still access all of the TFS settings. Within Visual Studio 2012 I can access all sections except "Security" and "Group Membership" under the "Team Project" and "Team Project Collection" headings. Upon clicking any of those I get the error message:

Team Foundation Error

Logon failure: unknown user name or bad password

The same username/password is used in both versions of Visual Studio.

Note: This computer is NOT connected to the domain, although it is using domain credentials for TFS. I've heard that there may be an issue with Team Explorer in Visual Studio 2012 when using domain credentials for the connection but not being logged into the computer as a domain user. Can anyone confirm this or offer any steps that I can try?

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

I have experienced a similar issue. The work around that we are now using for it is to run VS using our domain credentials. For some reason, your TFS credentials are not enough when running on machines where you are not logged into the domain.

runas /netonly /user: "C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\devenv.exe"

share|improve this answer
    
That did it! Thanks for the work around. –  Coder6841 Sep 21 '12 at 1:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.