Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using OSX 10.8.1 in combination with iTerm2, zsh and tmux via Homebrew.

The beginning of my ~/.tmux.conf file looks like this:

set -g prefix C-a
unbind C-b
bind-key a send-prefix
set -sg escape-time 1

When I start tmux and press C-a c, nothing happens. When I spam C-a c fast enough then some new tabs open up, but not the equivalent count of my command spaming. When I press C-a first followed by c, nothing happens again. Is there a delay issue or what's up with my tmux installation/configuration?

share|improve this question
    
I'm using iTerm2, MacPorts' tmux & bash, but it shouldn't really matter; what you have should work regardless of bash vs. zsh and, in theory, Homebrew vs. MacPorts. I can only guess that there's something wrong with Homebrew's tmux... –  Joe Casadonte Sep 13 '12 at 0:30
    
The strange thing is, a friend of mine is using Homebrew's tmux and it is working fine. But I'm going to try another tmux installation, just for testing. –  Marc Sep 13 '12 at 10:10
    
You could try to get rid of the escape-time; it didn't cause any problems with my tmux, but I'm not sure that it's needed and it's possible that it could be getting in the way, somehow. –  Joe Casadonte Sep 14 '12 at 2:10
    
I just put it into my config to test it. It doesn't matter if it is in my config or not, the issue persists. –  Marc Sep 14 '12 at 8:49
add comment

2 Answers

up vote 2 down vote accepted

You need to use "tmux2", which has iTerm2 integration. As you're using Homebrew, this will work:

[ kill/quit all running tmux sessions ]

$ brew tap adamv/alt

$ brew remove tmux   # Repeat this until you get an
                     # error to clean everything out

$ brew install tmux-iterm2

Then, open an iTerm2 window and type tmux -C to begin.

share|improve this answer
    
I just reinstalled iTerm2 and replaced the stable version with the beta one. Don't know if the beta release fixed the issue or just a reinstall of iTerm2 did that, but everything works fine now. No need of tmux integration of iTerm2. Btw there is no "tmux-iterm2" brew formula. Nevertheless, thanks for your answer! –  Marc Oct 16 '12 at 8:53
    
There is, in the adamv/alt (homebrew-alt) tap. –  Félix Saparelli Oct 16 '12 at 20:51
add comment

Do you press C-a and THEN c? In screen, you can do C-a THEN c OR C-a+c. I usually use the later and that one is not working for me and I'm quite disappointed...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.