Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

EDIT: using the "change user" login screen, when reloging into the account, all icons are restored ok. So it seems the question is closed.

using the "view" menu item in the TFS dialog box to open an exe file (in TFS) i forgot to uncheck the "always open with" checkbox.

Now in Windows all .exe files are associated with the program i choose (notepad), and all icons of program files are the icon of notepad.

I managed to revert the default "open" action on .exe files so i can now run any program without opening notepad.

But i'm stuck with the notepad icons displayed on all my programs. I've deleted the iconcache.db file, and run a .reg file to "restore" default associations of EXE files in Windows 7. Rebooted. Nothing happens, notepad icon stays everywhere.

What registry key should i delete in my profile to get back the original icons for all .EXE files ?

share|improve this question

migrated from stackoverflow.com Sep 12 '12 at 19:46

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Ben N, nc4pk, DavidPostill windows Jan 23 at 17:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I trust that Visual Studio 2012 did not change EXE default association to NotePad. Normally virus / trojan does the job. – Raptor Sep 12 '12 at 10:51
    
No, the association was changed because of me, using VS2012. I can post screen shots of how to reproduce the problem. There is a missing guard against this unwanted change in VS TFS View dialog for exe files that are in TFS. – Softlion Sep 12 '12 at 11:24
up vote 1 down vote accepted

Use this REG file and import it, assuming yours is still using the default registry path. May need administrator account.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\exefile\DefaultIcon]
@="%1"
share|improve this answer
    
This registry value is already set to %1. I think it is somewhere in the current profile registry hive (HKU). – Softlion Sep 12 '12 at 16:25
    
Can you post the exported registry of HKEY_CLASSES_ROOT\.exe and HKEY_CLASSES_ROOT\exefile to a code snippetting website (I forgot its URL)? – Jay Sep 12 '12 at 16:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.