Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install the GMP package on Redhat 4, x86_64. The package can only be installed using make, which is not available and should be installed with apt-get/yum, but I don't have either one of them. I tried installing them using rpm, but they each require lots of dependencies themselves, which although finite in amount seem like a VERY tedious job to do.

Any help on how I should go about solving this?

share|improve this question

migrated from stackoverflow.com Sep 13 '12 at 8:20

This question came from our site for professional and enthusiast programmers.

    
This is clearly not a programming question. –  unwind Sep 13 '12 at 8:19
    
yum groupinstall “Development Tools” –  hovanessyan Sep 13 '12 at 8:19
    
redhat 4 ? just install a fresh OS... –  Karoly Horvath Sep 13 '12 at 8:21
2  
he might mean RHEL 4 –  tumchaaditya Sep 13 '12 at 8:53
1  
It can't be redhat 4! Not if it is x86_64. (can it?) –  richard Sep 13 '12 at 9:44

4 Answers 4

Why don't you install yum manually via rpm?

Manually install YUM via RPM in Centos 5

To manually reinstall yum, run the following commands:

rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/gmp-4.1.4-10.el5.x86_64.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/readline-5.1-3.el5.x86_64.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/python-2.4.3-27.el5.x86_64.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/libxml2-2.6.26-2.1.2.8.x86_64.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/libxml2-python-2.6.26-2.1.2.8.x86_64.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/expat-1.95.8-8.3.el5_4.2.x86_64.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/python-elementtree-1.2.6-5.x86_64.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/sqlite-3.3.6-5.x86_64.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/python-sqlite-1.1.7-1.2.1.x86_64.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/elfutils-libelf-0.137-3.el5.x86_64.rpm
rpm –nodeps -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/elfutils-0.137-3.el5.x86_64.rpm
rpm –nodeps -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/rpm-4.4.2.3-18.el5.x86_64.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/rpm-python-4.4.2.3-18.el5.x86_64.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/m2crypto-0.16-6.el5.6.x86_64.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/python-urlgrabber-3.1.0-5.el5.noarch.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/yum-metadata-parser-1.1.2-3.el5.centos.x86_64.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/python-iniparse-0.2.3-4.el5.noarch.rpm
rpm –nodeps -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/yum-fastestmirror-1.1.16-14.el5.centos.1.noarch.rpm
rpm -Uvh http://mirror.centos.org/centos/5/os/x86_64/CentOS/yum-3.2.22-26.el5.centos.noarch.rpm
yum -y update

Source

share|improve this answer
    
I already tried that, but the links are broken... –  Dimen Shaw Sep 13 '12 at 14:03

Redhat 4 is pretty old (1996), so the modern tools which automatically download dependencies aren't available.

The system was probably installed from a DVD or a set of CD ROMs. Find those. That way, you will at least have all the files readily available.

Or you can try this recipe to install yum on Redhat 4.

Note: Unless there is a really good reason to keep this ancient system alive, consider upgrading to a more recent version. Linux systems are pretty secure but that's only true as long as you install every update. If that system is connected to the Internet, chances are that it's not your own system anymore ...

share|improve this answer
    
he might mean RHEL 4 –  tumchaaditya Sep 13 '12 at 8:53
    
I'm not sure how I got confused. Misinformation deleted. –  Eroen Sep 13 '12 at 15:19

You can download make directly from the GNU website. You should also install a C compiler such as gcc.

share|improve this answer

RHEL4 does not have yum. On that version you use up2date to install software if you are subscribed to Red Hat's software channels.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.