Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So, the situation is like this:

I'm renting an apartment in a large house and I'm sharing internet with the landlord who lives downstairs.

The internet is (in my best guess) optical 20/20Mbit. I don't know how it's all wired in his flat (haven't been there / seen it).

Anyway, in my flat comes a cable which seems to be connected directly to the optic to ethernet router (and the password is the default one, so I have access, he he). There was a switch connected to that and to wires that go around the flat, and the wiring is terrible. It's even mixing phone and ethernet, and from what I see some cables are even interconnected!?

Anyways, this cable that comes to my flat is very short. I can barely connect my computer on it, but if I do, I seem to get decent speed / performance. Not great, but decent.

If, however, I connect switch to it (tried 2 different switches and a wifi switch) it's all blinking but I can't even connect to (the router). DHCP fails, ping is losing 80-100% of replies.

So I connected this cable directly to the other cable which goes to my work room, with a connector that has two female jacks and no electronics. Now when I connect my computer in my room, again, the performance is decent.

When I connect WRT54GL (with tomato, DHCP disabled) to it and I plug a cable in this WRT and to my computer... the performance is gone. Download seems okay on Speedtest, but upload is .2Mbps and it's connecting forever.

So what kind cable troll am I having here? Any ideas?

share|improve this question
Are you using a switch or a hub? And is it Ethernet powered, or does it have a power-supply that plugs into the wall socket? Also, have you contacted Cisco customer support? Maybe your landlord has something that can ID the product types connected to it via their MAC addresses. What happens if you set your router to use your computers MAC address? Just throwing out ideas. – James K Sep 13 '12 at 21:33
Did you set the default gateway of your switches (if they have that option) to Also, you might need to disable DHCP on your switches, assuming that the main house router already provides a DHCP server. – sblair Sep 13 '12 at 21:53
I tried switches with external power supply. Why contacting Cisco? The same happens with cisco and non-cisco equipment. Landlord has nothing specific IMHO - i mean, it doesn't work with switch and switch has no mac address. He could have a faulty switch in the loop though! Yes, GW is ok, DHCP is disabled. – Foo Bar Sep 14 '12 at 5:23
what you describe is bit similar to mismatched duplex problems. – wmz Sep 15 '12 at 10:00

>ping is losing 80-100% of replies. this tells us your problem is a hardware problem then forget about DHCP config, default gateways configs and the like.

Your land lord cable is ok, now try to see if the cable that you use from your computer to the switch is also ok, next try to test if all the switch ports present the same behavior.

again get focused on hardware stuff

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.