Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When PDF files are returned by a Google search, sometimes I'd like to just download them, rather than viewing them in the browser.

Google results with a PDF

How on earth do I do this in Chrome?

I can't right-click the link and Save As, because that link isn't really to the PDF.

Note: This is not a duplicate of Download arbitrary file with Google Chrome because the solution given was to simply right-click and Save As, which does not work in this situation.

share|improve this question
    
It's not really a link (anymore), that's why you can't right it and select Save As. –  James K Sep 13 '12 at 22:05
    
It is a link, but the URL is actually google.co.uk/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&c... –  Rocketmagnet Sep 13 '12 at 22:07
    
I didn't mean the blue link text, I meant the green text used to be a link, but Google changed that some time ago. About the same time that the advanced search switches + and - started bringing up empty searches. –  James K Sep 13 '12 at 22:29
    
Stupid Google... –  Rocketmagnet Sep 13 '12 at 22:36
1  
Indeed. It's like their motto has changed to "Don't be evil, just be annoying." –  James K Sep 13 '12 at 22:51

4 Answers 4

The only way I know to do this for a PDF file would be to disable Chrome's automatic mode of opening PDF's.

I'm using the latest Chrome on OS X:

Chrome Menu -> Settings -> Advanced Settings -> Content Settings -> Disable Individual Plugins -> Disable Chrome's PDF Reader

Or the short way: chrome://plugins

Now when you click the file it should automatically download it.

You can further read about disabling PDF in Browser over here: Stop PDFs from displaying inside Google Chrome

Hope that helps!

share|improve this answer
    
Thanks. This is such an annoying lack of a feature. My usual method is to write an HTML file, and put the URL in as a link so that I can open it up and do save as. –  Rocketmagnet Sep 13 '12 at 22:03

EDIT: Actually I misunderstood your question. You can just load the PDF page and the press CTRL+S.

Google is trying to gather more information by first sending you to a google URL that then forwards you to the PDF. That's why the plain-text "link" is no-longer an actual link.


You can select / highlight the text URL, right click on it, the click "go to www.glyn.de/data..."

Google Results

Once the page is loaded, press CTRL+S

share|improve this answer
    
No, that does not save the file. Again it tries to open it in the browser. –  Rocketmagnet Sep 13 '12 at 21:48
    
Much better! Chrome tries to load the PDF (and as usual Adobe dies for some reason) but I can still save with ctrl+S. –  Rocketmagnet Sep 13 '12 at 22:07

Mr. Justin Pot describes what to do for Chrome and Firefox here: http://www.makeuseof.com/tag/copy-crapfree-urls-googles-search-results/

Summary: Chrome: Install 'Don't track me Google'

Firefox: Install the Firefox addin 'Google/Yandex search link fix'

PS. This issue had caused me to change my home page to search.yahoo.com - I still have the Google search tool however at the top.

With Yahoo, the links are real links, so you can click 'Save Link As' and save your PDF as you used to be able to.

(You also get the old Google cached links which is another benefit)

share|improve this answer

When you perform a Google query, the links in the results page do not actually point to the pages you expect. Instead, they point to a Google server which logs which link you click and then redirects you to the actual page. They do this so that they can track the results (i.e., which of the results we found were actually desirable by the user?)

The problem is that they trick users and hide this behavior. When the page loads, it uses JavaScript to print the actual/correct URL to the status bar when you hover the cursor over a link in the results page, but the link still points to page on their servers instead of the page/resource expected. That’s why when you try to save a non-HTML result, you get the wrong thing.

(You can actually see the redirection in action by right-clicking a link, dismissing the context-menu, then hovering over a link. You’ll notice that the correct URL is show before right-clicking, and then the Google URL is shown after. In fact, if you disable JavaScript altogether, the hiding mechanism goes away and you can see that the links are all to Google’s server.)

There is an easy fix however, just install a browser extension to override this tracking and make the links point to the actual pages/files. There are plenty available; just search for Google tracking or something to that effect. Note however that not all will work correctly, so you may have to test a few. My personal recommendation is the googlePrivacy user-script. Not only does it work, but because it’s just a user-script instead of a full-fledge extension, it doesn’t use as much resources.

Now, whenever a Google search returns non-HTML results, you can simply right-click the link and select Save As or hold Alt (or ⌥ (Option) on Macs) and left-click it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.