Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So...I'm on the second worst series of operating system in the world, using my everyday vim text editor, and...yeah...I have no idea. I guess its a bug, I'm running 10.7 Lion with nothing installed except homebrew itself, using the default terminal.app. Anyone know why this is happening? Or know how to fix it. Or have a suggestion for it?

~/.vimrc:

set number
set expandtab
set tabstop=2
syntax on

Here is a screenshot:

enter image description here

share|improve this question
2  
"I guess it's a bug." -- Experience teaches us that in 99.9% of cases, this guess is wrong. –  DevSolar Sep 14 '12 at 8:02

1 Answer 1

:h e492 says:

You tried to execute a command that is neither an Ex command nor a user-defined command.

Did you, by any chance, type :dw? If Vim was your "everyday text editor" you would surely know that :dw makes no sense at all as dw is not an Ex command.

Type dw in normal mode to delete to the end of the word under your cursor.

Also there's no need to criticize the OS. The fact that you are not comfortable with it is not an indication of how crappy it is.

share|improve this answer
    
Yes, I'm in normal mode, it works perfectly in my Arch Linux setup. I am a very avid user for Vi and Vim. I know how it works. Though there isn't a delete-word command for the vim editor for Mac OS X Dawin Unix terminal. I type d and then w, or use the command, and both of them give me that error. :| –  TenorB Sep 14 '12 at 15:00
1  
Yes, both dw and :d[elete] work in Mac OS X's default Vim, of course. Is there even a way to build Vim without it? This error is raised when you issue an Ex command that doesn't exist and Ex commands are issued in the command-line, after you hit a colon. The only explanation I see is that you have issued :dw and you got this error, just like I did here. dw would have worked without error, :d would have worked without error, even :d w (while the two later have very different results), but not :dw. Check your ~/.vimrc if you have one. –  romainl Sep 14 '12 at 15:23
    
The issue is, when I type dw or use the command ":d" or ":dw" nothing happens except for an error. –  TenorB Sep 15 '12 at 0:03
    
That's extremelly weird. I've used the default Vim for a while and never encountered that problem. Do you have a custom ~/.vimrc? Could you post its content? dw and :d are so basic they should work everywhere. :dw doesn't exist so the error is normal. –  romainl Sep 15 '12 at 6:30
    
Updated OP, hopefully that might have something to do with it... –  TenorB Sep 15 '12 at 21:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.