Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there any way how to repeat last executed command (like up arrow does is cmd.exe) in Console2?

share|improve this question
    
The manual does say: Windows (CR+LF) - If selected the copy operation will convert the carriage return using the Windows convention. I don't know what that actually means but may be it will help –  Dave Sep 14 '12 at 12:39
1  
Um... I use Console2, and the up arrow works... –  SaintWacko Sep 14 '12 at 13:10
    
Yeah, I tried walkthough in this article: instructables.com/id/… and it sort of stopped working (probably). –  Marek Osvald Sep 14 '12 at 13:50

5 Answers 5

up vote 1 down vote accepted

[I stand corrected, as per comments, ctrl + works]

From the developers themselves (at least, their source code):

NOTE: Console is NOT a shell. Therefore, it does not implement shell features like...command history

Source: http://console.git.sourceforge.net/git/gitweb.cgi?p=console/console;a=blob;f=help/html/introduction.html;h=3b7e5dcc8948366941e371dfe4946e2431d4e434;hb=041d573f735c50926185657558fb5491f0871dfd

share|improve this answer
    
Ha! Nevermind, i figured it out. All you have to do is press Ctrl+Up. Weird that the developers say the application does not support this function though. –  Marek Osvald Sep 14 '12 at 12:46
    
Haha, well, to be fair the help file is usually the last thing I remember to update too. –  EntropyWins Sep 14 '12 at 12:48
    
You make a help file?! I just assume everyone will know by magic :) –  Dave Sep 14 '12 at 12:49
    
I make a help file because I forget the s**t I code sometimes. –  EntropyWins Sep 14 '12 at 12:59
    
I just discovered that Shift + ↑ works as well. –  Marek Osvald Sep 18 '12 at 9:49

You have to go to Settings -> Hotkeys and disable Use scroll lock for scrolling. This worked fine for me!

share|improve this answer
    
thx, save my time –  slier Sep 18 '13 at 15:44
    
This fixed the case where arrow keys (both up/down and left/right) cause scrolling instead of keypresses being passed on to the actual interpreter. Thanks! –  efdee Mar 3 at 15:29

If it was working previously, and suddenly stopped, you may have hit the scroll lock key.

share|improve this answer

I had the same issue and none of the instructions above worked for me.

In my case noticed that in Settings -> Hotkeys UP and DOWN were assigned to "Scroll Buffer row up" and "Scroll Buffer row down", so I assigned something else to these Commands (ie: Crtl + UP, Crtl + DOWN) and the UP and DOWN keys started working again to navigate the history.

share|improve this answer

As a work around, in the Settings - Behavior screen under Copy and Paste you can select Copy on Select. I know not ideal but may be the closest you can get.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.